aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:44 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:23 +0200
commite5bf0cfa97f524f73c20e3be9a5470b2e2ce3754 (patch)
tree30547bd860a2f91c15cf28374ebfa8fe25cfdb6f /gnu/packages
parent003441743ecb79589d6ac13c2bc0c8baa1e6ff56 (diff)
downloadguix-e5bf0cfa97f524f73c20e3be9a5470b2e2ce3754.tar.gz
guix-e5bf0cfa97f524f73c20e3be9a5470b2e2ce3754.zip
gnu: cpuinfo: Update to commit 05332fd.
Also disable tests on aarch64, because they fail in the build container. * gnu/packages/parallel.scm (cpuinfo): Update to commit 05332fd. [arguments]<#:tests?>: Disable on aarch64. [supported-systems]: Remove field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/parallel.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index cb2aad0ca4..d5a55a8641 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -536,7 +536,7 @@ features.")
;; There's currently no tag on this repo.
(let ((version "0.0")
(revision "3")
- (commit "aa4b2163b99ac9534194520f70b93eeefb0b3b4e"))
+ (commit "05332fd802d9109a2a151ec32154b107c1e5caf9"))
(package
(name "cpuinfo")
(version (git-version version revision commit))
@@ -547,10 +547,13 @@ features.")
(file-name (git-file-name name version))
(sha256
(base32
- "12x4krkyzxngf1l2ck33lnsp8pyzf6gyjj9mp9cnka9mw3h6617m"))))
+ "0w0kfc1fn9viirkhbr8dgfy9m5clfsg3k9p6kdxhzqpyjhgd252n"))))
(build-system cmake-build-system)
(arguments
(list
+ ;; cpuinfo does not work in the build container for aarch64:
+ ;; https://github.com/pytorch/cpuinfo/issues/143
+ #:tests? (not (target-aarch64?))
#:configure-flags
'(list "-DBUILD_SHARED_LIBS=ON"
"-DUSE_SYSTEM_LIBS=ON")
@@ -569,9 +572,6 @@ GTEST_SKIP() << \"See https://github.com/pytorch/cpuinfo/issues/132\";"))))))))
"The cpuinfo library provides a C/C++ and a command-line interface to
obtain information about the CPU being used: supported instruction set,
processor name, cache information, and topology information.")
- ;; On aarch64-linux, there is a bug reported upstream:
- ;; https://github.com/pytorch/cpuinfo/issues/14
- (supported-systems '("armhf-linux" "i686-linux" "x86_64-linux"))
(license license:bsd-2))))
(define-public clog