aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-17 22:39:41 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-20 22:43:43 +0300
commite518d2f8546a5dfde8d4644e3e9c55ac358efab7 (patch)
tree5f937e29e630eb8d0460746adc4aa30286fff742 /gnu/packages
parent163843c78ebd673044e14320f539462fa5826d14 (diff)
downloadguix-e518d2f8546a5dfde8d4644e3e9c55ac358efab7.tar.gz
guix-e518d2f8546a5dfde8d4644e3e9c55ac358efab7.zip
gnu: Add go-suah-dev-protect.
* gnu/packages/golang-xyz.scm (go-suah-dev-protect): New variable. Change-Id: Idf224b6571da2aefb99811ee3cd9fead67614d61
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f8c63976d6..ae19116b51 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8842,6 +8842,32 @@ go-github-com-orisano-pixelmatch source.")))
" This package provides an command line interface (CLI)
tool."))))
+(define-public go-suah-dev-protect
+ (package
+ (name "go-suah-dev-protect")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/qbit/protect")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f36w2435xivggl4d31813ggk37ya9v8q6w8ygbp35ypzwfgzlh3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "suah.dev/protect"))
+ (home-page "https://codeberg.org/qbit/protect")
+ (synopsis "Wrapper for OpenBSD's pledge and unveil system calls.")
+ (description
+ "Package protect is a wrapper for OpenBSD's @code{pledge} and @code{unveil}
+system calls.
+
+It allows one to safely call Unveil / Pledge on non-OpenBSD operating systems.")
+ (license license:isc)))
+
(define-public go-tengo
(package
(inherit go-github-com-d5-tengo-v2)