aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-10-04 11:20:30 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-10-14 15:31:28 +0200
commite4fb70e2e87d8746d534ed295e79ab1ae3666a47 (patch)
treea47b1b17ca313e0bbc2a70a142c66b9c454a6b86 /gnu/packages
parent8e8d20b6b35d3ab529f9045cc8a779cdcec9c471 (diff)
downloadguix-e4fb70e2e87d8746d534ed295e79ab1ae3666a47.tar.gz
guix-e4fb70e2e87d8746d534ed295e79ab1ae3666a47.zip
gnu: guile-proba: Fix environment vars in Guile Proba's script.
* gnu/packages/check.scm (guile-proba): Micro fix. Guile Proba's CLI script, as created via Guix's `wrap-program', should take into account (as opposed to discard) the original, user-defined values of `GUILE_LOAD_PATH' and `GUILE_LOAD_COMPILED_PATH'. Currently, Guile Proba's CLI script is unable to find any third-party library needed by the app being tested. This micro change should fix this. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1e4edd5b6e..cf26196a24 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3599,8 +3599,8 @@ that can be used to verify that future runs produce the same data.")
(copy-file "proba.scm" script)
(chmod script #o555)
(wrap-program script
- `("GUILE_LOAD_PATH" = (,(getenv "GUILE_LOAD_PATH")))
- `("GUILE_LOAD_COMPILED_PATH" =
+ `("GUILE_LOAD_PATH" prefix (,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
(,(getenv "GUILE_LOAD_COMPILED_PATH")))))))
(add-after 'install 'install-manual
(lambda* (#:key outputs #:allow-other-keys)
d>Tobias Geerinckx-Rice 2020-01-17Update email address for Amin Bandali....* .mailmap: Add name and email addresses for Amin Bandali. * gnu/local.mk, gnu/packages/emacs-xyz.scm, gnu/packages/emacs.scm, gnu/packages/fpga.scm, gnu/packages/lean.scm, gnu/packages/maths.scm: Update email address for Amin Bandali. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Amin Bandali 2019-12-19Update email for Brett Gilio....* .mailmap: Add name and email for Brett Gilio. * gnu/local.mk, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/bittorrent.scm, gnu/packages/build-tools.scm, gnu/packages/cran.scm, gnu/packages/emacs-xyz.scm, gnu/packages/messaging.scm, gnu/packages/python-xyz.scm, gnu/packages/sml.scm, gnu/packages/terminals.scm, gnu/packages/wm.scm: Update email for Brett Gilio. Brett Gilio 2019-12-18gnu: leocad: Update to 19.07.1....* gnu/packages/lego.scm (leocad): Update to 19.07.1 [source]: Use git-fetch. * .mailmap: Add preferred alias for myself. Eric Bavier