aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-30 12:37:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-30 13:03:30 +0200
commite42e4cecd0bfea023953696a5cf1eb544247ddcf (patch)
treee58f6efa045032eea3e89e983bce9e9ca453c613 /gnu/packages
parentf3baa5da06159853ba63c5e666cfc32bb41b0c7c (diff)
downloadguix-e42e4cecd0bfea023953696a5cf1eb544247ddcf.tar.gz
guix-e42e4cecd0bfea023953696a5cf1eb544247ddcf.zip
gnu: Add r-flowai.
* gnu/packages/bioconductor.scm (r-flowai): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fe446df67a..ba46686095 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14341,6 +14341,46 @@ gene fusion discovery. It can be applied to all major sequencing techologies
and to both short and long sequence reads.")
(license license:gpl3)))
+(define-public r-flowai
+ (package
+ (name "r-flowai")
+ (version "1.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "flowAI" version))
+ (sha256
+ (base32
+ "18zrlnjw89iglxhw65ys8x4r44pdzp5chrgwx7w44sh7yd8576g9"))))
+ (properties `((upstream-name . "flowAI")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-changepoint
+ r-flowcore
+ r-ggplot2
+ r-knitr
+ r-plyr
+ r-rcolorbrewer
+ r-reshape2
+ r-rmarkdown
+ r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/flowAI")
+ (synopsis
+ "Automatic and interactive quality control for flow cytometry data")
+ (description
+ "This package is able to perform an automatic or interactive quality
+control on FCS data acquired using flow cytometry instruments. By evaluating
+three different properties:
+
+@enumerate
+@item flow rate
+@item signal acquisition, and
+@item dynamic range,
+@end enumerate
+
+the quality control enables the detection and removal of anomalies.")
+ (license license:gpl2+)))
+
(define-public r-flowutils
(package
(name "r-flowutils")