aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 20:57:26 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:21 +0100
commite4070d404d5daa71fcc83a7fecc9b58570d280c2 (patch)
treecaa1fb0681b26ce13f2c61ac59252f372605defb /gnu/packages
parentaf76eedac08caeb267f4f47ebdf85ef4c01c8fd6 (diff)
downloadguix-e4070d404d5daa71fcc83a7fecc9b58570d280c2.tar.gz
guix-e4070d404d5daa71fcc83a7fecc9b58570d280c2.zip
gnu: ocaml-bisect: Remove package.
* gnu/packages/ocaml.scm (ocaml-bisect): Remove deprecated package, replaced by ocaml-bisect-ppx.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c0b8154079..1710aadb90 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1261,53 +1261,6 @@ full_split, cut, rcut, etc..")
;; where it says `mit'.
(license license:expat)))
-(define-public ocaml-bisect
- (package
- (name "ocaml-bisect")
- (version "1.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gasche/bisect.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hm5za61qydda6ri3887b4zqqbqilh42x712xnclm1rr7ggga2nh"))
- (patches
- (search-patches
- "ocaml-bisect-fix-camlp4-in-another-directory.patch"))))
- (build-system ocaml-build-system)
- (native-inputs
- `(("camlp4" ,camlp4)
- ("libxml2" ,libxml2)
- ("ocamlbuild" ,ocamlbuild)
- ("which" ,which)))
- (propagated-inputs
- `(("camlp4" ,camlp4)))
- (arguments
- `(#:test-target "tests"
- #:make-flags
- (list "all" (string-append "CAMLP4_LIBDIR="
- (assoc-ref %build-inputs "camlp4")
- "/lib/ocaml/site-lib/camlp4"))
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "./configure" "-prefix" (assoc-ref outputs "out")
- "-ocaml-prefix" (assoc-ref inputs "ocaml")
- "-camlp4-prefix" (assoc-ref inputs "camlp4"))
- #t)))))
- (home-page "http://bisect.x9c.fr")
- (synopsis "Code coverage tool for the OCaml language")
- (description "Bisect is a code coverage tool for the OCaml language. It is
-a camlp4-based tool that allows to instrument your application before running
-tests. After application execution, it is possible to generate a report in HTML
-format that is the replica of the application source code annotated with code
-coverage information.")
- (license license:gpl3+)))
-
(define-public dune
(package
(name "dune")
6:28 +0800'>2015-12-13gnu: Add modem-manager....* gnu/packages/freedesktop.scm (modem-manager): New variable. 宋文武 2015-12-13gnu: Add libqmi....* gnu/packages/freedesktop.scm (libqmi): New variable. 宋文武 2015-12-13gnu: Add libmbim....* gnu/packages/freedesktop.scm (libmbim): New variable. 宋文武 2015-11-05gnu: wayland: Update to 1.9.0....* gnu/packages/freedesktop.scm (wayland): Update to 1.9.0. Tomáš Čech 2015-11-01gnu: udisks: Separate HTML documentation....* gnu/packages/freedesktop.scm (udisks)[outputs]: New field. [arguments]: Pass the --with-html-dir configure flag. Ludovic Courtès 2015-11-01gnu: udisks: Mount things under /media....* gnu/packages/freedesktop.scm (udisks)[arguments]: Add --enable-fhs-media. Ludovic Courtès 2015-11-01gnu: udisks: Find the 'mount' command....* gnu/packages/freedesktop.scm (udisks)[inputs]: Add UTIL-LINUX. [arguments]: Add 'set-mount-file-name' phase. Ludovic Courtès 2015-10-20Merge branch 'master' into dbus-updateMark H Weaver 2015-10-18gnu: elogind: Provide the file name of 'halt' and 'reboot'....* gnu/packages/freedesktop.scm (elogind)[inputs]: Add DMD. Ludovic Courtès 2015-10-18gnu: elogind: Fix build by explicitly link with librt....* gnu/packages/freedesktop.scm (elogind)[arguments]: Pass 'LDFLAGS=-lrt' to configure. 宋文武 2015-09-02gnu: elogind: Update to version 219.12....* gnu/packages/freedesktop.scm (elogind): Update to 219.12. Use a tarball instead of a git checkout. Andy Wingo 2015-08-22gnu: Add accountsservice....* gnu/packages/freedesktop.scm (accountsservice): New variable. 宋文武 2015-08-20gnu: libinput: Update to 0.21.0....* gnu/packages/freedesktop.scm (libinput): Update to 0.21.0. 宋文武 2015-07-26gnu: Add udisks....* gnu/packages/freedesktop.scm (udisks): New variable. 宋文武 2015-07-26gnu: Add libatasmart....* gnu/packages/freedesktop.scm (libatasmart): New variable. 宋文武 2015-07-18gnu packages: Clean up synopses and descriptions....* gnu/packages/admin.scm, gnu/packages/algebra.scm, gnu/packages/audio.scm, gnu/packages/backup.scm, gnu/packages/base.scm, gnu/packages/bittorrent.scm, gnu/packages/code.scm, gnu/packages/compression.scm, gnu/packages/databases.scm, gnu/packages/enchant.scm, gnu/packages/firmware.scm, gnu/packages/fonts.scm, gnu/packages/freedesktop.scm, gnu/packages/games.scm, gnu/packages/gd.scm, gnu/packages/gl.scm, gnu/packages/gnome.scm, gnu/packages/gsasl.scm, gnu/packages/gstreamer.scm, gnu/packages/gtk.scm, gnu/packages/guile.scm, gnu/packages/haskell.scm, gnu/packages/language.scm, gnu/packages/lesstif.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/llvm.scm, gnu/packages/maths.scm, gnu/packages/mcrypt.scm, gnu/packages/mit-krb5.scm, gnu/packages/mp3.scm, gnu/packages/ncdu.scm, gnu/packages/networking.scm, gnu/packages/ntp.scm, gnu/packages/ocaml.scm, gnu/packages/openbox.scm, gnu/packages/pdf.scm, gnu/packages/perl.scm, gnu/packages/pretty-print.scm, gnu/packages/pulseaudio.scm, gnu/packages/python.scm, gnu/packages/rdesktop.scm, gnu/packages/rdf.scm, gnu/packages/ruby.scm, gnu/packages/slang.scm, gnu/packages/slim.scm, gnu/packages/telephony.scm, gnu/packages/tls.scm, gnu/packages/tmux.scm, gnu/packages/tre.scm, gnu/packages/unrtf.scm, gnu/packages/version-control.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/wget.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xiph.scm: Fix typos. Trim long lines. Add missing periods in the end of sentences. Use double spaces between sentences. Remove trailing whitespaces. Alex Kost 2015-07-17gnu: Add exempi....* gnu/packages/freedesktop.scm (exempi): New variable. David Hashe 2015-07-14gnu: Add libxdg-basedir....* gnu/packages/freedesktop.scm (libxdg-basedir): New variable. Alex Kost 2015-06-17gnu: Add wayland....* gnu/packages/freedesktop.scm (wayland): New variable. 宋文武 2015-05-06gnu: Add python-pyxdg....* gnu/packages/freedesktop.scm (python-pyxdg, python2-pyxdg): New variables. Ricardo Wurmus 2015-05-06gnu: Add elogind....* gnu/packages/freedesktop.scm (elogind): New variable. Ricardo Wurmus 2015-04-23gnu: libinput: Update to 0.14.1....* gnu/packages/freedesktop.scm (libinput): Update to 0.14.1. 宋文武 2015-04-03gnu: Add libinput....* gnu/packages/freedesktop.scm (libinput): New variable. 宋文武 2015-02-14gnu: Add xdg-utils....* gnu/packages/freedesktop.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. Andreas Enge