aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:13:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:10 +0200
commite325aacc499c7f1e0a89284fc27e0668570501fb (patch)
tree3d26f66fc14494c6487b0b0921c41c11f7e7c614 /gnu/packages
parent54ffc9e7fcb3400c88f98bc5b4a486bb5b916c03 (diff)
downloadguix-e325aacc499c7f1e0a89284fc27e0668570501fb.tar.gz
guix-e325aacc499c7f1e0a89284fc27e0668570501fb.zip
gnu: Add texlive-mathtools.
* gnu/packages/tex.scm (texlive-mathtools): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bb03ccfbe2..daf275f2a3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10356,6 +10356,41 @@ sets. LaTeX macro support is provided in package @code{psnfss}.")
XeLaTeX with arbitrary text fonts using @code{fontspec} as a backend.")
(license license:lppl)))
+(define-public texlive-mathtools
+ (package
+ (name "texlive-mathtools")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mathtools/"
+ "source/latex/mathtools/"
+ "tex/latex/mathtools/")
+ (base32
+ "11rs5wd1m5f3y309gdlq47vj3xzs8m87qlbd7b6glhq8lx8wfbd6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mathtools")
+ (synopsis "Mathematical tools to use with @code{amsmath}")
+ (description
+ "Mathtools provides a series of packages designed to enhance the
+appearance of documents containing a lot of mathematics. It is based on
+@code{amsmath} and fixes various deficiencies of it and standard LaTeX. It
+provides:
+@itemize
+@item Extensible symbols, such as brackets, arrows, harpoons, etc.;
+@item Various symbols such as \\coloneqq (:=);
+@item Easy creation of new tag forms;
+@item Showing equation numbers only for referenced equations;
+@item Extensible arrows, harpoons and hookarrows;
+@item Starred versions of the @code{matrix} environments for specifying the
+column alignment;
+@item More building blocks: multlined, cases-like environments, new gathered
+environments;
+@item Maths versions of @code{\\makebox}, @code{\\llap}, @code{\\rlap} etc.;
+@item Cramped math styles; and more...
+@end itemize")
+ (license license:lppl1.3c)))
+
(define-public texlive-fp
(package
(name "texlive-fp")