aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-20 22:36:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-20 22:38:14 +0100
commite2bfbba33eebdae2226cdbaf2e78204eb727ea5b (patch)
treed44717a61136016910f91b8814f70e3dcff02686 /gnu/packages
parent909a5122c65d521b2b7f85e947dd8c0fae7e23e8 (diff)
downloadguix-e2bfbba33eebdae2226cdbaf2e78204eb727ea5b.tar.gz
guix-e2bfbba33eebdae2226cdbaf2e78204eb727ea5b.zip
gnu: Add python-ircmatch.
* gnu/packages/irc.scm (python-ircmatch): New variable. Change-Id: I50d8aec4ff264c897f255ca81e61a74644c34f91
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/irc.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index d6b8cf4b4b..75f0ebe482 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -849,6 +849,25 @@ interface for those who are accustomed to the ircII way of doing things.")
"This package provides an IRC library for Python, based on asyncio.")
(license license:isc)))
+(define-public python-ircmatch
+ (package
+ (name "python-ircmatch")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ircmatch" version))
+ (sha256
+ (base32 "1bn92bnk958c097jhwkas24i4a07h905hifix7bg111npc48536l"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pypi.org/project/ircmatch/")
+ (synopsis "Library for matching IRC masks based on atheme")
+ (description "This is a python extension which provides string comparison
+and matching functions from Atheme. They are hand-optimized for high
+performance when matching IRC hostmasks.")
+ (license license:isc)))
+
(define-public python-irc-parser-tests
(package
(name "python-irc-parser-tests")