aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-08-31 22:26:48 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-08-31 22:31:51 -0400
commite05f0e9832326703fa90a02559f1a4b44e4401ad (patch)
tree254599bd67d969a84a2f189f6f4fef54bed523f0 /gnu/packages
parent9626feb1cb1704cd026cd1177f77f71e64b7396d (diff)
downloadguix-e05f0e9832326703fa90a02559f1a4b44e4401ad.tar.gz
guix-e05f0e9832326703fa90a02559f1a4b44e4401ad.zip
gnu: tomlplusplus: Fix build.
* gnu/packages/cpp.scm (tomlplusplus)[arguments]<#:phases>: Move the "C" locale to part of the utf8 locale list. [native-inputs]: Add ‘libc-utf8-locales-for-target’. Change-Id: I1e6362dd27e88d22e1c40aea1ccf1767c93fbeac
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 93ffef3989..4951fdbc44 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages benchmark)
#:use-module (gnu packages boost)
@@ -914,11 +915,12 @@ intuitive syntax and trivial integration.")
(lambda _
(substitute* "tests/meson.build"
(("foreach locale : test_locales" all)
- (format #f "test_locales = ['C', ~{'~a.utf8', ~}]~%~a"
+ (format #f "test_locales = [~{'~a.utf8', ~}]~%~a"
;; %default-utf8-locales in (gnu packages base).
- '("de_DE" "el_GR" "en_US" "fr_FR" "tr_TR")
+ '("C" "de_DE" "el_GR" "en_US" "fr_FR" "tr_TR")
all))))))))
- (native-inputs (list cmake-minimal))
+ ;; Tests require locales.
+ (native-inputs (list cmake-minimal (libc-utf8-locales-for-target)))
(home-page "https://marzer.github.io/tomlplusplus/")
(synopsis "Header-only TOML config file parser and serializer for C++17")
(description