aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:12:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:05 +0200
commitdfee2a969ef21b676aaf2561060b7ed193fa407f (patch)
tree7280ef7328a26f54968a8eaf6a7736d30b9b2950 /gnu/packages
parent47a32dd3e9dad20a2cdff3e2d4dac5afbdc55cc2 (diff)
downloadguix-dfee2a969ef21b676aaf2561060b7ed193fa407f.tar.gz
guix-dfee2a969ef21b676aaf2561060b7ed193fa407f.zip
gnu: Add texlive-combinedgraphics.
* gnu/packages/tex.scm (texlive-combinedgraphics): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 16be1cd669..edf3311833 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16616,6 +16616,32 @@ saved by printing stains directly on the page rather than adding them
manually.")
(license license:public-domain)))
+(define-public texlive-combinedgraphics
+ (package
+ (name "texlive-combinedgraphics")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/combinedgraphics/"
+ "source/latex/combinedgraphics/"
+ "tex/latex/combinedgraphics/")
+ (base32
+ "1jb0bc5s8kn5aplgmry94laj92c2h16xv77km6fz0pcd4wvpng6i")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/combinedgraphics")
+ (synopsis "Include graphic (EPS or PDF)/LaTeX combinations")
+ (description
+ "This package provides the @code{\\includecombinedgraphics} macro for the
+inclusion of combined EPS/LaTeX and PDF/LaTeX graphics. Instead of including
+the graphics with a simple @code{\\input}, the
+@code{\\includecombinedgraphics} macro has some comforts: changing the font
+and color of the text of the LaTeX part; rescaling the graphics without
+affecting the font of the LaTeX part; automatic inclusion of the vector
+graphics part, as far as LaTeX part does not do it; and rescaling and rotating
+of complete graphics.")
+ (license license:gpl3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")