aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 19:22:58 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 19:25:16 +0000
commitdddc90a3637f960a12f82e0587c0514fc79e32f4 (patch)
treefac96fc930711d16139bd8f2792e63ea8afd2f13 /gnu/packages
parent2691864533aa1d557838bc842aa88b2f9daa37d4 (diff)
downloadguix-dddc90a3637f960a12f82e0587c0514fc79e32f4.tar.gz
guix-dddc90a3637f960a12f82e0587c0514fc79e32f4.zip
gnu: shorah: Use GUIX_PYTHONPATH in wrapper.
* gnu/packages/bioinformatics.scm (shorah)[arguments]: Wrap executable with GUIX_PYTHONPATH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f2d53360a4..60ae3e1601 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8275,7 +8275,7 @@ data. It also generates basic statistics for your sequences.")
(pythonpath (getenv "GUIX_PYTHONPATH"))
(script (string-append out "/bin/shorah")))
(chmod script #o555)
- (wrap-program script `("PYTHONPATH" ":" prefix (,site ,pythonpath))))))
+ (wrap-program script `("GUIX_PYTHONPATH" ":" prefix (,site ,pythonpath))))))
(add-after 'wrap-programs 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
: Clarify 'git-fetch' conventions....Ludovic Courtès 2020-06-04doc: cookbook: Add entry about getting substitutes through Tor....Brice Waegeneire 2020-06-02doc: cookbook: Add entry about Wireguard VPN....Marcin Karpezo 2020-05-25doc: cookbook: Add subsection about session locking with xss-lock....Chris Bøg 2020-05-05doc: cookbook: Fix sbcl-ttf-fonts package name....Jean-Baptiste Note 2020-04-30doc: cookbook: Rename stumpwm package to current state....Marcin Karpezo 2020-04-25doc: cookbook: Fix quotes....Nicolas Goaziou 2020-04-24doc: cookbook: Use @file for file names and extensions....Nicolas Goaziou 2020-04-24doc: cookbook: Fix misuses of double spacing....Nicolas Goaziou 2020-04-22doc: cookbook: Explain how to use bind mounts....Matthew Brooks 2020-03-30gnu: Add sbcl-stumpwm-ttf-fonts....Oleg Pykhalov 2020-01-17doc: cookbook: Avoid URL reference to the manual....Ludovic Courtès 2019-11-26doc: cookbook: Add cross-references to the Guile manual....Ludovic Courtès 2019-11-26doc: cookbook: Use @result{} & co. instead of a '>' prompt....Ludovic Courtès 2019-11-26doc: cookbook: Use Texinfo quotes....Ludovic Courtès 2019-11-26doc: cookbook: Add cross-reference about ./pre-inst-env....Ludovic Courtès 2019-11-26doc: cookbook: Use @lisp for Scheme snippets....Ludovic Courtès 2019-10-30doc: Explain how to switch profile from empty shell in "Profiles in Practice"....Pierre Neidhardt 2019-10-28doc: Link to SICP Info page in "A Scheme Crash Course"....Pierre Neidhardt 2019-10-28doc: Finish importing the "Packaging Tutorial"....Pierre Neidhardt 2019-10-28doc: Fix some typos in "Guix Profiles in Practice"....Pierre Neidhardt 2019-10-25doc: cookbook: Use "@lisp" for Scheme snippets....Ludovic Courtès 2019-10-24doc: Add "Guix Profiles in Practice" to the cookbook....Pierre Neidhardt 2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus