aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-10 21:27:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:21 +0000
commitdb9d704290719e4caf01322c1e1bbbf02d7b2c29 (patch)
tree9c030f264d92fb69c75d384c60d84bde49694b24 /gnu/packages
parent5c3e101ef470e7ee80fed1bc7afdf6fdf9ed4e7b (diff)
downloadguix-db9d704290719e4caf01322c1e1bbbf02d7b2c29.tar.gz
guix-db9d704290719e4caf01322c1e1bbbf02d7b2c29.zip
gnu: python-curio: Update to 1.6.
* gnu/packages/python-xyz.scm (python-curio): Update to 1.6. [build-system]: Swap to pyrpoject-build-system. [arguments]<test-flags>: Move deselect options here, ignore more shaky tests. <phases>: Use default 'check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I58a4098cbcf5063f88e41711fc06608520853e4e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 23 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a89044e80..e914b88efc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16479,30 +16479,36 @@ printing of sub-tables by specifying a row range.")
(define-public python-curio
(package
(name "python-curio")
- (version "1.5")
+ (version "1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "curio" version))
(sha256
- (base32 "045wwg16qadsalhicbv21p14sj8i4w0l57639j7dmdqbb4p2225g"))))
- (build-system python-build-system)
+ (base32 "0isj3jl5mx6m25nr1f7r91hfaydhkvmks9p85dyvl5h2n9nmhajn"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; Tries to open an outgoing connection.
- "not test_ssl_outgoing "
- ;; This test fails since Python 3.9.9 (see:
- ;; https://github.com/dabeaz/curio/issues/347).
- "and not test_timeout"))))))))
+ (list
+ #:test-flags
+ #~(list ;; AttributeError: 'NoneType' object has no attribute
+ ;; 'terminate'
+ "--deselect=tests/test_workers.py::test_exception"
+ ;; Tries to open an outgoing connection.
+ "--deselect=tests/test_network.py::test_ssl_outgoing"
+ ;; This test fails since Python 3.9.9, see
+ ;; <https://github.com/dabeaz/curio/issues/347>.
+ ;; AttributeError: 'NoneType' object has no attribute
+ ;; 'terminate'
+ "--deselect=tests/test_workers.py::test_worker_timeout"
+ ;; AttributeError: 'NoneType' object has no attribute
+ ;; 'terminate'
+ "--deselect=tests/test_workers.py::test_bad_cpu"
+ "--deselect=tests/test_workers.py::test_cpu"
+ "--deselect=tests/test_workers.py::test_worker_cancel")))
(native-inputs
- (list python-pytest))
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/dabeaz/curio")
(synopsis "Coroutine-based library for concurrent Python")
(description