aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2024-12-02 13:38:06 -0800
committerVagrant Cascadian <vagrant@debian.org>2024-12-09 10:40:57 -0800
commitda3c8a963f83c044568d99921480259eaa26a923 (patch)
tree07af14e52b2744a5408ad2f0743c862086cc9b9d /gnu/packages
parenta5a540d71331fd43fd53e23eb49102c55462c28f (diff)
downloadguix-da3c8a963f83c044568d99921480259eaa26a923.tar.gz
guix-da3c8a963f83c044568d99921480259eaa26a923.zip
gnu: guile-ssh: Update to 0.18.0.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.18.0. [source]: Drop patch, fixed upstream. * gnu/packages/patches/guile-ssh-rename-bool.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Update with removed patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/guile-ssh-rename-bool.patch40
-rw-r--r--gnu/packages/ssh.scm5
2 files changed, 2 insertions, 43 deletions
diff --git a/gnu/packages/patches/guile-ssh-rename-bool.patch b/gnu/packages/patches/guile-ssh-rename-bool.patch
deleted file mode 100644
index 17697dacb2..0000000000
--- a/gnu/packages/patches/guile-ssh-rename-bool.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From ad0af631250ce3399127d42995cc0bef6ad3ee5e Mon Sep 17 00:00:00 2001
-From: Herman Rimm <herman@rimm.ee>
-Date: Sun, 18 Aug 2024 16:05:44 +0200
-Subject: [PATCH] libguile-ssh/session-func: Fix variable name
-
-* libguile-ssh/session-func.c (set_bool_opt): Rename bool to boolean.
----
- libguile-ssh/session-func.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/libguile-ssh/session-func.c b/libguile-ssh/session-func.c
-index 7006b62..b379472 100644
---- a/libguile-ssh/session-func.c
-+++ b/libguile-ssh/session-func.c
-@@ -228,18 +228,18 @@ set_int32_opt (ssh_session session, int type, SCM value)
- return ssh_options_set (session, type, &c_value);
- }
-
--/* Convert VALUE to integer that represents a boolan value (0
-+/* Convert VALUE to integer that represents a boolean value (0
- considered as false, any other value is true), and pass it to
- ssh_options_set */
- static inline int
- set_bool_opt (ssh_session session, int type, SCM value)
- {
-- int32_t bool;
-+ int32_t boolean;
-
- SCM_ASSERT (scm_is_bool (value), value, SCM_ARG3, "session-set!");
-
-- bool = scm_to_bool (value);
-- return ssh_options_set (session, type, &bool);
-+ boolean = scm_to_bool (value);
-+ return ssh_options_set (session, type, &boolean);
- }
-
- /* Convert VALUE to a socket file descriptor and pass it to
---
-2.45.2
-
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 95ad38a642..8d7c975d35 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -334,7 +334,7 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.17.0")
+ (version "0.18.0")
(home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
(method git-fetch)
@@ -342,10 +342,9 @@ Additionally, various channel-specific options can be negotiated.")
(url home-page)
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (patches (search-patches "guile-ssh-rename-bool.patch"))
(sha256
(base32
- "1lkhpgbzvh6i1sc4nmdc9rx9yzrdyjxxjb8x6nvq2zif8xy9y9vg"))))
+ "0zh1spkjl5q778y4rd6ml68fvz1r62xmk03khi4kp74z2rxgzcxb"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments