aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:16:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:04 +0200
commitd95ec770db23fceda3237c55bca767ee4a54d10c (patch)
treed9c6ae86e55b75690290b2938e036a2d1ba3d63a /gnu/packages
parenteba7c513cf6fdf688bad2870345d7a9b0cdaf60d (diff)
downloadguix-d95ec770db23fceda3237c55bca767ee4a54d10c.tar.gz
guix-d95ec770db23fceda3237c55bca767ee4a54d10c.zip
gnu: emacs-epl: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-epl)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 05343be43f..5e51743a5c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4386,15 +4386,15 @@ It is recommended to use @code{clojure-mode} with paredit or smartparens.")
(package
(name "emacs-epl")
(version "0.8")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/cask/epl/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1511n3a3f5gvaf2b4nh018by61ciyzi3y3603fzqma7p9hrckarc"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cask/epl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sjxd5y5hxhrbgfkpwx6m724r3841b53hgc61a0g5zwispw5pmrr"))))
(build-system emacs-build-system)
(home-page "https://github.com/cask/epl")
(synopsis "Emacs Package Library")