aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:25:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:07 +0200
commitd82680e614dfc696635e87d125228220ed02f903 (patch)
treeab9737f1de90e84a2cd62c84c07f0d0424570276 /gnu/packages
parentaad5c928c42219a08b051c6f52c1e5ecb73848a9 (diff)
downloadguix-d82680e614dfc696635e87d125228220ed02f903.tar.gz
guix-d82680e614dfc696635e87d125228220ed02f903.zip
gnu: emacs-highlight-sexp: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-highlight-sexp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae10dd3788..35d6717a7d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6361,14 +6361,13 @@ jQuery and Bootstrap resources included via osscdn.")
(version "1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/daimrod/highlight-sexp/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/daimrod/highlight-sexp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0jwx87qkln1rg9wmv4qkgkml935fh2pkgrg5x4ca6n5dgb4q6rj1"))))
+ (base32 "12cyk2q5g6p4ac2hykw1cag7dp1prjjnck5f7nalwwaklmy62y79"))))
(build-system emacs-build-system)
(home-page "https://github.com/daimrod/highlight-sexp")
(synopsis "Minor mode that highlights the s-exp at the current position")