aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-07 02:49:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-07 15:37:12 +0100
commitd4f5e68e55d15f851ad4d820a5384123d9b51441 (patch)
tree32b63b276ec8332e12f7c079457ac8e8587c329f /gnu/packages
parent45298300e43d314f9001c2bdbd72f1189e20eb70 (diff)
downloadguix-d4f5e68e55d15f851ad4d820a5384123d9b51441.tar.gz
guix-d4f5e68e55d15f851ad4d820a5384123d9b51441.zip
gnu: cmdtest: Update to 0.32.
* gnu/packages/check.scm (cmdtest): Update to 0.32.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 50b4afcaf0..686c2e2b27 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -202,14 +202,14 @@ multi-paradigm automated test framework for C++ and Objective-C.")
(define-public cmdtest
(package
(name "cmdtest")
- (version "0.29")
+ (version "0.32")
(source (origin
(method url-fetch)
(uri (string-append "http://git.liw.fi/cmdtest/snapshot/"
name "-" version ".tar.gz"))
(sha256
(base32
- "1i6gi4yp4qqx1liax098c7nwdb24pghh11xqlrcs7lnhh079rqhb"))))
+ "1jmfiyrrqmpvwdb273bkb8hjaf4rwx9njblx29pmr7giyahskwi5"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2
(modules '((guix build utils))) (snippet #~(begin (substitute* (list "src/config/core/CMakeLists.txt" "src/config/contrib/CMakeLists.txt") (("include/pkgconfig") "lib/pkgconfig") (("include/cmake") "share/cmake/lucene++")))))) (build-system cmake-build-system) (arguments (list #:configure-flags #~(list (string-append "-DLIB_DESTINATION:PATH=" #$output "/lib") "-DINSTALL_GTEST:BOOL=OFF") #:phases #~(modify-phases %standard-phases (replace 'check ;; XXX Tests are built unconditionally during the 'build phase. ;; There's no ‘test’ target. README.md suggests running this. (lambda* (#:key tests? #:allow-other-keys) (when tests? (invoke "src/test/lucene++-tester" "--test_dir=../source/src/test/testfiles"))))))) (native-inputs (list pkg-config)) (inputs (list boost zlib)) (home-page "https://github.com/luceneplusplus/LucenePlusPlus") (synopsis "Text search engine") (description "Lucene++ is an up to date C++ port of the popular Java Lucene library, a high-performance, full-featured text search engine.") (license (list license:asl2.0 license:lgpl3+)))); either asl or lgpl. (define-public lrdf (package (name "lrdf") (version "0.6.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/swh/LRDF") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "00wzkfb8y0aqd519ypz067cq099dpc89w69zw8ln39vl6f9x2pd4")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-after 'unpack 'remove-out-of-tree-references (lambda _ ;; remove_test depends on an out-of-tree RDF file (substitute* "examples/Makefile.am" (("instances_test remove_test") "instances_test") (("\\$\\(TESTS\\) remove_test") "$(TESTS)")) #t)) ;; The default bootstrap phase executes autogen.sh, which fails. (replace 'bootstrap (lambda _ (invoke "autoreconf" "-vif") #t))))) (inputs (list cyrus-sasl mit-krb5 nettle raptor2 zlib)) (native-inputs (list autoconf automake libtool pkg-config)) (home-page "https://github.com/swh/LRDF") (synopsis "Lightweight RDF library for accessing LADSPA plugin metadata") (description "LRDF is a library to make it easy to manipulate RDF files describing LADSPA plugins. It can also be used for general RDF manipulation. It can read RDF/XLM and N3 files and export N3 files, and it also has a light taxonomic inference capability.") (license license:gpl2))) (define-public rasqal (package (name "rasqal") (version "0.9.33") (source (origin (method url-fetch) (uri (string-append "http://download.librdf.org/source/" name "-" version ".tar.gz")) (sha256 (base32 "0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939")))) (build-system gnu-build-system) (native-inputs (list perl perl-xml-dom ; for the tests pkg-config)) (inputs (list libgcrypt libxml2 mpfr pcre `(,util-linux "lib"))) (propagated-inputs (list raptor2)) ; stipulated by rasqal.pc (arguments `(#:parallel-tests? #f ; test failure reported upstream, see ; http://bugs.librdf.org/mantis/view.php?id=571 #:tests? #f)) (home-page "https://librdf.org/rasqal/") (synopsis "RDF query library") (description "Rasqal is a C library that handles Resource Description Framework (RDF) query language syntaxes, query construction and execution of queries returning results as bindings, boolean, RDF graphs/triples or syntaxes. The supported query languages are SPARQL Query 1.0, SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental SPARQL extensions (LAQRS). Rasqal can write binding query results in the SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.") (license license:lgpl2.1+))) ; or any choice of gpl2+ or asl2.0 (define-public redland (package (name "redland") (version "1.0.17") (source (origin (method url-fetch) (uri (string-append "http://download.librdf.org/source/" name "-" version ".tar.gz")) (sha256 (base32 "109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y")))) (build-system gnu-build-system) (native-inputs (list perl ; needed for installation pkg-config)) (propagated-inputs (list rasqal)) ; in Requires.private field of .pc (inputs (list bdb)) (home-page "https://librdf.org/") (synopsis "RDF library") (description "The Redland RDF Library (librdf) provides the RDF API and triple stores.") (license license:lgpl2.1+))) ; or any choice of gpl2+ or asl2.0 (define-public serd (package (name "serd") (version "0.32.0") (source (origin (method url-fetch) (uri (string-append "https://download.drobilla.net/serd-" version ".tar.xz")) (sha256 (base32 "18cwj8xxsaq6iw45kcljbhrral0cqvav80p4mdv2l7g0d2a6ks6i")))) (build-system meson-build-system) (native-inputs (list python-minimal)) (home-page "https://drobilla.net/software/serd.html") (synopsis "Library for RDF syntax supporting Turtle and NTriples") (description "Serd is a lightweight C library for RDF syntax which supports reading and writing Turtle and NTriples. Serd is not intended to be a swiss-army knife of RDF syntax, but rather is suited to resource limited or performance critical applications (e.g. converting many gigabytes of NTriples to Turtle), or situations where a simple reader/writer with minimal dependencies is ideal (e.g. in LV2 implementations or embedded applications).") (license license:isc))) (define-public sord (package (name "sord") (version "0.16.16") (source (origin (method url-fetch) (uri (string-append "https://download.drobilla.net/sord-" version ".tar.xz")) (sha256 (base32 "1l2zjz6gypxbf1z32zyqkljdcn9mz452djc4xq1dlhv1fmnqfzr5")))) (build-system meson-build-system) (inputs (list pcre)) (native-inputs (list pkg-config)) (propagated-inputs (list serd zix)) ;required by sord-0.pc (home-page "https://drobilla.net/software/sord.html") (synopsis "C library for storing RDF data in memory") (description "Sord is a lightweight C library for storing RDF data in memory.") (license license:isc))) (define-public python-rdflib (package (name "python-rdflib") (version "6.1.1") (source (origin (method url-fetch) (uri (pypi-uri "rdflib" version)) (sha256 (base32 "0m7pyq771vl4zf9xd3pxjbg7x6ac97b3djfbv9qq9fch56ps1gwd")))) (build-system python-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-after 'unpack 'adjust-tests (lambda _ (for-each delete-file '(;; This test needs a font that is not shipped. "test/test_so_69984830.py" ;; These tests need internet access. "test/jsonld/test_onedotone.py" "test/test_sparql_service.py" "test/test_graph.py")))) (replace 'check (lambda* (#:key tests? #:allow-other-keys) (when tests? (invoke "pytest" "-vv" "test/"))))))) (native-inputs (list python-pytest)) (propagated-inputs (list python-html5lib python-isodate python-pyparsing)) (home-page "https://github.com/RDFLib/rdflib") (synopsis "Python RDF library") (description "RDFLib is a Python library for working with RDF, a simple yet powerful language for representing information.") (license (license:non-copyleft "file://LICENSE" "See LICENSE in the distribution.")))) (define-public python-cfgraph (package (name "python-cfgraph") (version "0.2.1") (source (origin (method url-fetch) (uri (pypi-uri "CFGraph" version)) (sha256 (base32 "0x7yz0lvqb6mkhl5fbml27sppmscgpf8v2ism9jzzf0h982ffzxm")))) (build-system python-build-system) (propagated-inputs (list python-rdflib)) (home-page "https://github.com/hsolbrig/CFGraph") (synopsis "RDF Collections flattener for rdflib") (description "This package contains RDF Collections flattener for @code{rdflib}.") (license license:asl2.0))) (define-public hdt-cpp (package (name "hdt-cpp") (version "1.3.3") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/rdfhdt/hdt-cpp") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1vsq80jnix6cy78ayag7v8ajyw7h8dqyad1q6xkf2hzz3skvr34z")))) (build-system gnu-build-system) (inputs (list serd zlib)) (native-inputs (list autoconf automake libtool pkg-config)) (home-page "https://github.com/rdfhdt/hdt-cpp") (synopsis "C++ implementation of the HDT compression format") (description "Header Dictionary Triples (HDT) is a compression format for RDF data that can also be queried for Triple Patterns. This package provides a C++ library as well as various command-line tools to to work with HDT.") (license license:lgpl2.1+))) (define-public python-pyrdfa3 (package (name "python-pyrdfa3") (version "3.6.2") (source (origin (method url-fetch) (uri (pypi-uri "pyRdfa3" version)) (sha256 (base32 "1hhlhgqkc3igzdpxllf41drrqxm5aswqhwvnjqb90q3zjnmiss3k")))) (build-system pyproject-build-system) (arguments (list #:tests? #f)) ;no test suite (propagated-inputs (list python-html5lib python-rdflib python-requests)) (home-page "https://www.w3.org/2012/pyRdfa/") (synopsis "RDFa Python distiller/parser library") (description "This library can extract RDFa 1.1 from (X)HTML, SVG, or XML. It can produce serialized versions of the extracted graph, or an RDFLib Graph.") (license license:bsd-3))) (define-public python-sparqlwrapper (package (name "python-sparqlwrapper") (version "2.0.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/RDFLib/sparqlwrapper") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "1b4vg754kcxvinwdv7pjfmwbnmgm50w8mb2naf2lwp27bpyllvkb")))) (build-system python-build-system) (arguments '(#:tests? #f)) ; The test suite simply queries external HTTP endpoints. (propagated-inputs (list python-rdflib)) (home-page "https://rdflib.dev/sparqlwrapper/") (synopsis "SPARQL Endpoint interface to Python") (description "Python wrapper around a SPARQL service. It helps in creating the query URI and, possibly, convert the result into a more manageable format.") (license license:w3c)))