aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 06:45:56 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 06:48:04 -0400
commitd41ba524ed4aab46a418fb2c1a0163b0d82bb87b (patch)
tree268efe71840e49fb56b847f3e70d39093fdb882d /gnu/packages
parentd1c86620f3a73a29615fcd7a7fe80918dc3cad8e (diff)
downloadguix-d41ba524ed4aab46a418fb2c1a0163b0d82bb87b.tar.gz
guix-d41ba524ed4aab46a418fb2c1a0163b0d82bb87b.zip
gnu: linux-libre-headers: Update to 4.14.26.
* gnu/packages/linux.scm (linux-libre-headers): Update to 4.14.26.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b764b56053..40f172c654 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -158,13 +158,13 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(define-public linux-libre-headers
(package
(name "linux-libre-headers")
- (version "4.9.59")
+ (version "4.14.26")
(source (origin
(method url-fetch)
(uri (linux-libre-urls version))
(sha256
(base32
- "0z8hq8a6ic38xh33idzl0k0yi4isgd7ncl2g1d6mzf9ixw5krhvc"))))
+ "1m2zr17wpasg5riysbaa4g5i492jzr93py2jm088ki818s4a9cm3"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(arguments
ext-to-store/add-to-store vs. delete-paths"): ... this test. Ludovic Courtès 2020-09-14daemon: Spawn 'guix authenticate' once for all....Previously, we'd spawn 'guix authenticate' once for each item that has to be signed (when exporting) or authenticated (when importing). Now, we spawn it once for all and then follow a request/reply protocol. This reduces the wall-clock time of: guix archive --export -r $(guix build coreutils -d) from 30s to 2s. * guix/scripts/authenticate.scm (sign-with-key): Return the signature instead of displaying it. Raise a &formatted-message instead of calling 'leave'. (validate-signature): Likewise. (read-command): New procedure. (define-enumerate-type, reply-code): New macros. (guix-authenticate)[send-reply]: New procedure. Change to read commands from current-input-port. * nix/libstore/local-store.cc (runAuthenticationProgram): Remove. (authenticationAgent, readInteger, readAuthenticateReply): New functions. (signHash, verifySignature): Rewrite in terms of the agent. * tests/store.scm ("import not signed"): Remove 'pk' call. ("import signed by unauthorized key"): Check the error message of C. * tests/guix-authenticate.sh: Rewrite using the new protocol. fixlet Ludovic Courtès 2020-09-11store: Test 'import-paths' with unauthorized and unsigned nar bundles....* tests/store.scm ("import not signed") ("import signed by unauthorized key"): New tests. Ludovic Courtès 2020-08-28store: 'with-store' returns as many values as its body....Fixes <https://bugs.gnu.org/42912>. Reported by Ricardo Wurmus <rekado@elephly.net>. * guix/store.scm (call-with-store)[thunk]: Wrap call to PROC in 'call-with-values'. * tests/store.scm ("with-store, multiple values"): New test. Ludovic Courtès