aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:30:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:57 +0200
commitca2240524ee6219d2f1097fce2446f0853841fe1 (patch)
tree378f63384fbe14843e5ea8633698c66781ad5ef6 /gnu/packages
parent1a1390ed3063b3d1b21c86a5d323a3001f6f9366 (diff)
downloadguix-ca2240524ee6219d2f1097fce2446f0853841fe1.tar.gz
guix-ca2240524ee6219d2f1097fce2446f0853841fe1.zip
gnu: Add texlive-matrix-skeleton.
* gnu/packages/tex.scm (texlive-matrix-skeleton): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ff97e762a7..33c63ee9fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4648,6 +4648,28 @@ pretty-print Matlab and Octave source code. (Note that support of Octave
syntax is not complete.)")
(license license:lppl1.3+)))
+(define-public texlive-matrix-skeleton
+ (package
+ (name "texlive-matrix-skeleton")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/matrix-skeleton/"
+ "tex/latex/matrix-skeleton/")
+ (base32
+ "07mqmc0kli0azp2vlzm8q3lp1b70lyggm2hqnq0v9c0jlfhvj9j7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/matrix-skeleton")
+ (synopsis
+ "PGF/TikZ library that simplifies working with multiple matrix nodes")
+ (description
+ "The package provides a PGF/TikZ library that simplifies working with
+multiple matrix nodes. To do so, it correctly aligns groups of nodes with the
+content of the whole matrix. Furthermore, @code{matrix-skeleton} provides
+rows and columns for easy styling.")
+ (license license:isc)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")