aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commitc617cbb0fb968cbe66ab4f7a003bc2ee6dc85868 (patch)
treea6e870eb9dcfa4c1c3a3e491abdcaf4f4124b1c9 /gnu/packages
parent99049df1d4de9033c09744f9576b9484d8abf06a (diff)
downloadguix-c617cbb0fb968cbe66ab4f7a003bc2ee6dc85868.tar.gz
guix-c617cbb0fb968cbe66ab4f7a003bc2ee6dc85868.zip
gnu: Add ghc-stm-delay.
* gnu/packages/haskell-xyz.scm (ghc-stm-delay): New variable. Change-Id: If9e20a2c103549de9b4b7d63158fe34165f6036a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2ff17e92b5..b3e7a45602 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11757,6 +11757,28 @@ features.")
source and a sink.")
(license license:bsd-3)))
+(define-public ghc-stm-delay
+ (package
+ (name "ghc-stm-delay")
+ (version "0.1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "stm-delay" version))
+ (sha256
+ (base32 "0cla21v89gcvmr1iwzibq13v1yq02xg4h6k9l6kcprj7mhd5hcmi"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "stm-delay")))
+ (home-page "https://github.com/joeyadams/haskell-stm-delay")
+ (synopsis "Updatable one-shot timer polled with STM")
+ (description
+ "This library lets you create a one-shot timer, poll it using STM, and
+update it to ring at a different time than initially specified. It uses GHC
+event manager timeouts when available, yielding performance similar to
+@code{threadDelay} and @code{registerDelay}. Otherwise, it falls back to
+forked threads and @code{threadDelay}.")
+ (license license:bsd-3)))
+
(define-public ghc-stmonadtrans
(package
(name "ghc-stmonadtrans")