aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-09 18:55:31 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-09 18:55:31 +0100
commitc4bd2aca00068c179c308256e6a8c04d7d3e108e (patch)
treee07fb04bbbb0fc60f0ef099abb2de46806bf93f0 /gnu/packages
parent922ea80683fa9ba5cc91818d2e2679b5c6c1fa6a (diff)
downloadguix-c4bd2aca00068c179c308256e6a8c04d7d3e108e.tar.gz
guix-c4bd2aca00068c179c308256e6a8c04d7d3e108e.zip
gnu: Add polkit.
* gnu/packages/polkit.scm (polkit): New variable. * gnu/packages/patches/polkit-drop-test.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch file.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/polkit-drop-test.patch18
-rw-r--r--gnu/packages/polkit.scm40
2 files changed, 57 insertions, 1 deletions
diff --git a/gnu/packages/patches/polkit-drop-test.patch b/gnu/packages/patches/polkit-drop-test.patch
new file mode 100644
index 0000000000..2fd0c8bdf6
--- /dev/null
+++ b/gnu/packages/patches/polkit-drop-test.patch
@@ -0,0 +1,18 @@
+Drop test failing with the following message:
+FAIL: polkitbackendjsauthoritytest
+==================================
+/PolkitBackendJsAuthority/get_admin_identities: Error getting system bus: Could not connect: No such file or directoryError loading /var/run/ConsoleKit/database: Error statting file /var/run/ConsoleKit/database: No such file or directory
+
+
+diff -ru polkit-0.112.old/test/Makefile.in polkit-0.112/test/Makefile.in
+--- polkit-0.112.old/test/Makefile.in 2013-07-08 22:52:13.000000000 +0200
++++ polkit-0.112/test/Makefile.in 2014-11-09 18:43:47.000000000 +0100
+@@ -388,7 +388,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = mocklibc . polkit polkitbackend
++SUBDIRS = mocklibc . polkit
+ AM_CFLAGS = $(GLIB_CFLAGS)
+ noinst_LTLIBRARIES = libpolkit-test-helper.la
+ libpolkit_test_helper_la_SOURCES = polkittesthelper.c polkittesthelper.h
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 6f143a6c7f..64576f6473 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -21,8 +21,13 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages perl)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml))
(define-public mozjs
(package
@@ -95,3 +100,36 @@ in C/C++.")
platform-neutral API for system level and libc-like functions. It is used
in the Mozilla clients.")
(license mpl2.0)))
+
+(define-public polkit
+ (package
+ (name "polkit")
+ (version "0.112")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.freedesktop.org/software/polkit/releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xkary7yirdcjdva950nqyhmsz48qhrdsr78zciahj27p8yg95fn"))
+ (patches (list (search-patch "polkit-drop-test.patch")))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("expat" ,expat)
+ ("glib" ,glib)
+ ("glib:bin" ,glib "bin") ; for glib-mkenums
+ ("intltool" ,intltool)
+ ("linux-pam" ,linux-pam)
+ ("mozjs" ,mozjs)
+ ("nspr" ,nspr)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (home-page "http://www.freedesktop.org/wiki/Software/polkit/")
+ (synopsis "Authorization API for privilege management")
+ (description "Polkit is an application-level toolkit for defining and
+handling the policy that allows unprivileged processes to speak to
+privileged processes. It is a framework for centralizing the decision
+making process with respect to granting access to privileged operations
+for unprivileged applications.")
+ (license lgpl2.0+)))