aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-08 12:06:34 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:21 +0200
commitc48f44644425692418d6e551dc7ff67686552386 (patch)
tree9795525fbaf88bfaa08121a5e2db9e82094d62f5 /gnu/packages
parent6b995da47a146e12cea4ee718e8a314bcc74eae0 (diff)
downloadguix-c48f44644425692418d6e551dc7ff67686552386.tar.gz
guix-c48f44644425692418d6e551dc7ff67686552386.zip
gnu: rust: Run linker under C.UTF-8 instead of en_US.UTF-8.
This is a followup to 02d21712be1eb31a917313662b924763e81affb3. * gnu/packages/rust.scm (rust-1.55)[arguments]: In ‘set-linker-locale-to-utf8’, change to C.UTF-8. Change-Id: I94f27123ca8ac4761fd9bae6267c3a9d122b3a1d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index fa0c4e5854..e5e58ca8d3 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -446,7 +446,7 @@ safety and thread safety guarantees.")
(lambda _
(substitute* (find-files "." "^linker.rs$")
(("linker.env\\(\"LC_ALL\", \"C\"\\);")
- "linker.env(\"LC_ALL\", \"en_US.UTF-8\");"))))
+ "linker.env(\"LC_ALL\", \"C.UTF-8\");"))))
(add-after 'unpack 'add-cc-shim-to-path
(lambda _
(mkdir-p "/tmp/bin")