aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-01 21:17:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:10 +0100
commitc4542bd3c14e29cf55192fe556a91a7b0b4738bb (patch)
tree4483687e329ca663512b69b08488a2c45d9b4a8c /gnu/packages
parent547a66446b0116c8381cf32224ee83fcf1362d55 (diff)
downloadguix-c4542bd3c14e29cf55192fe556a91a7b0b4738bb.tar.gz
guix-c4542bd3c14e29cf55192fe556a91a7b0b4738bb.zip
gnu: Add go-github-com-pion-srtp-v2.
* gnu/packages/golang-web.scm (go-github-com-pion-srtp-v2): New variable. Change-Id: I94f6d6e9f79a2888631a2688dca04a02818565c0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5ab46d31a3..58821efff9 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3785,6 +3785,36 @@ Protocol,SCTP} as specified in
"Package sdp implements @acronym{Session Description Protocol,SDP}.")
(license license:expat)))
+(define-public go-github-com-pion-srtp-v2
+ (package
+ (name "go-github-com-pion-srtp-v2")
+ (version "2.0.20")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/srtp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ijwx9mrc0ha8fam6y6xxih59dyr8hg9ly476kv6gfw564qfp7hk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/srtp/v2"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-github-com-pion-rtcp
+ go-github-com-pion-rtp
+ go-github-com-pion-transport-v2))
+ (home-page "https://github.com/pion/srtp")
+ (synopsis "Implementation of SRTP protocol in Golang")
+ (description
+ "Package srtp implements Secure Real-time Transport Protocol.")
+ (license license:expat)))
+
(define-public go-github-com-pion-stun
(package
(name "go-github-com-pion-stun")