aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-13 09:02:41 -0500
committerjgart <jgart@dismail.de>2024-07-13 09:05:18 -0500
commitc0ecad208e305b6cd73a4ab0879e3407b879e1f9 (patch)
treed5f9880c0abc2216fde41dba1dba2154f6d1b839 /gnu/packages
parentddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3 (diff)
downloadguix-c0ecad208e305b6cd73a4ab0879e3407b879e1f9.tar.gz
guix-c0ecad208e305b6cd73a4ab0879e3407b879e1f9.zip
gnu: python-requests-toolbelt: Use new style.
* gnu/packages/python-xyz.scm (python-requests-toolbelt) [arguments]: Use new style. Change-Id: Ifbb305babeff37a34ca8789c3a08e0363e8583bf
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 62e92fc9a7..1067f800e0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3768,19 +3768,20 @@ portions of your testing code.")
"1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
(build-system python-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'delete-problematic-tests
- (lambda _
- ;; Fails because of expired certificate.
- (delete-file "tests/test_x509_adapter.py")
- ;; Fails due to networking (socket.gaierror: [Errno -2]
- ;; Name or service not known).
- (delete-file "tests/test_multipart_encoder.py")
- ;; Those tests are not compatible with urllib3 2.0,
- ;; according to
- ;; https://github.com/requests/toolbelt/pull/356
- (delete-file "tests/test_sessions.py")
- )))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-problematic-tests
+ (lambda _
+ ;; Fails because of expired certificate.
+ (delete-file "tests/test_x509_adapter.py")
+ ;; Fails due to networking (socket.gaierror: [Errno -2]
+ ;; Name or service not known).
+ (delete-file "tests/test_multipart_encoder.py")
+ ;; Those tests are not compatible with urllib3 2.0,
+ ;; according to
+ ;; https://github.com/requests/toolbelt/pull/356
+ (delete-file "tests/test_sessions.py"))))))
(native-inputs
(list python-betamax python-pyopenssl python-pytest python-trustme))
(propagated-inputs