aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 11:54:19 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:44 +0000
commitc0abeb4efa67e8e179c5eebef093cc247ac6ea51 (patch)
treeab46b7de42e65d2ba38f175923e91dad2d2295ab /gnu/packages
parent95438d9f2bbd6dc5cc8de965be6d9b399a27732f (diff)
downloadguix-c0abeb4efa67e8e179c5eebef093cc247ac6ea51.tar.gz
guix-c0abeb4efa67e8e179c5eebef093cc247ac6ea51.zip
gnu: Add python-pytoolconfig.
* gnu/packages/python-xyz.scm (python-pytoolconfig): New variable. Change-Id: I203d68b0eba0b38020a1be98904be386dfc3b2ed
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a4a06233f5..ec29634b63 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2238,6 +2238,33 @@ task of adding retry behavior to just about anything.")
implementation for the Telegram Bot API.")
(license license:gpl2)))
+(define-public python-pytoolconfig
+ (package
+ (name "python-pytoolconfig")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytoolconfig" version))
+ (sha256
+ (base32 "1bnvg9yiwp2fn0lvzhp1dd2mvrymxvjnasmbdap3i0hhdwdbvrji"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-packaging
+ python-platformdirs
+ python-pydantic
+ python-sphinx
+ python-sphinx-autodoc-typehints
+ python-sphinx-rtd-theme
+ python-tabulate
+ python-tomli))
+ (native-inputs (list python-pdm-backend python-pytest))
+ (home-page "https://pypi.org/project/pytoolconfig/")
+ (synopsis "Python tool configuration")
+ (description "The goal of this project is to manage configuration for
+Python tools, such as rope and add support for a @file{pyproject.toml}
+configuration file.")
+ (license license:lgpl3+)))
+
(define-public python-colorlog
(package
(name "python-colorlog")
rization. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Bruno Victal