aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-28 19:11:18 +0300
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-29 11:20:57 +0800
commitc061a7175df839ed4cbb06dc34ffee83130aac46 (patch)
treed653c43438f6d89d63e7a09df828159d54c26e3f /gnu/packages
parent7779ed9aedb3f417280fedbfe7b85504d7fcfc3b (diff)
downloadguix-c061a7175df839ed4cbb06dc34ffee83130aac46.tar.gz
guix-c061a7175df839ed4cbb06dc34ffee83130aac46.zip
gnu: uriparser: Update to 0.9.8.
* gnu/packages/web.scm (uriparser): Update to 0.9.8. [source]: Switch to git-fetch. Change-Id: I12ed35eebd9719aac83e5838cdec6e81529763ae Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5f7b2b92b0..ec2d4af322 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -9349,15 +9349,16 @@ tools:
(define-public uriparser
(package
(name "uriparser")
- (version "0.9.6")
+ (version "0.9.8")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/uriparser/uriparser"
- "/releases/download/uriparser-"
- version "/uriparser-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uriparser/uriparser")
+ (commit (string-append "uriparser-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0i7nxgy36i8v81r213sbvmpxxq9qb4rhii9qbvl1k32jd1ka1252"))))
+ "0qr3rc0iz1zxim1ylwzf7zijgnxpzv4m35fzvv5kf66a8bqhrw2k"))))
(build-system cmake-build-system)
(native-inputs (list googletest doxygen graphviz))
(synopsis "Strictly RFC 3986 compliant URI parsing and handling library")