aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-08-23 16:12:24 -0300
committerVinicius Monego <monego@posteo.net>2024-09-02 17:42:34 -0300
commitc01a99bb34a4a99c9dd3adab9dbaa9ca28fc6486 (patch)
tree01003d1c914c0dbebb0ed19dd11f39a38c9d414e /gnu/packages
parente407613e33e2eba6255c202363605f4ec1e61886 (diff)
downloadguix-c01a99bb34a4a99c9dd3adab9dbaa9ca28fc6486.tar.gz
guix-c01a99bb34a4a99c9dd3adab9dbaa9ca28fc6486.zip
gnu: python-libensemble: Update to 1.4.2.
* gnu/packages/maths.scm (python-libensemble): Update to 1.4.2. [propagated-inputs]: Add python-mpmath. [arguments]: Delete a file that contains a failing test. Change-Id: I76deae624b7f2bede63ad1b2bcf445c5aae53953
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a308d5db65..2fe64d4aee 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -886,13 +886,13 @@ LP/MIP solver is included in the package.")
(define-public python-libensemble
(package
(name "python-libensemble")
- (version "1.3.0")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "libensemble" version))
(sha256
- (base32 "0ckmr04z7ai9mar58si0wzyyy8dnq6g89pg57mzmfz5mkbg4fbsa"))))
+ (base32 "0qxb0sn624jaxjxg2ayd65zaiq1p043w3kk55w8r6drkjiar70yj"))))
(build-system pyproject-build-system)
(native-inputs (list ncurses
python-mock
@@ -900,7 +900,8 @@ LP/MIP solver is included in the package.")
python-pytest
python-pytest-cov
python-pytest-timeout))
- (propagated-inputs (list python-numpy
+ (propagated-inputs (list python-mpmath
+ python-numpy
python-psutil
python-pydantic-2
python-pyyaml
@@ -921,6 +922,10 @@ LP/MIP solver is included in the package.")
"libensemble/tests/unit_tests/test_executor.py")
(delete-file
"libensemble/tests/unit_tests/test_executor_gpus.py")
+ ;; This file has one failing MPI test but since tests run from
+ ;; a shell script, they can't be disabled individually.
+ ;; Failing test: 'test_ensemble_prevent_comms_overwrite'
+ (delete-file "libensemble/tests/unit_tests/test_ensemble.py")
(setenv "TERM" "xterm")
;; A very bad way to skip another MPI test.
(substitute* "libensemble/tests/run-tests.sh"