aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-22 19:08:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-23 00:06:51 +0100
commitbc0eb34759113f1d9b99ff83416c64eb1b35e0ae (patch)
tree3bc9436958c29ad72318a734886f3426437c8098 /gnu/packages
parentf17bd3c6465b941ef62091a8701de8c0cf822f4d (diff)
downloadguix-bc0eb34759113f1d9b99ff83416c64eb1b35e0ae.tar.gz
guix-bc0eb34759113f1d9b99ff83416c64eb1b35e0ae.zip
gnu: alpine: Remove pre-built binaries from source.
* gnu/packages/mail.scm (alpine)[source]: Add a snippet to hunt down and destroy pre-compiled objects.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 67afea68fb..64f679e662 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2748,7 +2748,13 @@ operators and scripters.")
(commit "abeb2c25935ef8c75f1e5deef0f81276754dc975")))
(file-name (git-file-name name version))
(sha256
- (base32 "0rqgbw08a5lj41dkp82aq480lqkc4bnxagna7wpqffi821n8gkwz"))))
+ (base32 "0rqgbw08a5lj41dkp82aq480lqkc4bnxagna7wpqffi821n8gkwz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-built binaries scattered across the source repository.
+ (for-each delete-file (find-files "." "\\.(dll|exe)"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "CC=gcc")
1:52:51 -0400'>2022-08-11build: marionette: Adjust QEMU Info manual reference....Maxim Cournoyer 2022-08-10gnu: system: file-systems: Add shared flag....Oleg Pykhalov 2022-08-09tests: Add qemu-guest-agent system test....Timotej Lazar 2022-07-20gnu: modifying make-chromium-extension to rely on node-crx3....Nicolas Graves 2022-07-01file-systems: Add 'cleanly-unmounted-ext2?'....Ludovic Courtès 2022-06-24image: Add support for 32bit UEFI....Denis 'GNUtoo' Carikli 2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer 2022-05-31image: Add fat32 support....Pavel Shlyak 2022-05-23image: Add bootable flag support....Pavel Shlyak 2022-05-22marionette: Add #:address parameter to 'wait-for-tcp-port'....Ludovic Courtès 2022-05-01Add (guix least-authority)....Ludovic Courtès 2022-05-01linux-container: Add #:child-is-pid1? parameter to 'call-with-container'....Ludovic Courtès 2022-05-01linux-container: Ensure signal-handling asyncs get a chance to run....Ludovic Courtès 2022-05-01linux-container: 'call-with-container' relays SIGTERM and SIGINT....Ludovic Courtès 2022-04-12shepherd: Add #:supplementary-groups....Leo Nikkilä 2022-04-11shepherd: 'fork+exec-command/container' always returns a PID....Ludovic Courtès 2022-04-11shepherd: 'exec-command*' has a valid default #:directory....Ludovic Courtès 2022-04-08file-systems: Invoke fsck tools with 'system*/tty'....Ludovic Courtès 2022-04-08mapped-devices: Ensure 'cryptsetup open' gets a tty....Ludovic Courtès 2022-04-07secret-service: Allow cooperative scheduling when Fibers is used....Ludovic Courtès 2022-04-07secret-service: Abstract 'wait-for-readable-fd'....Ludovic Courtès 2022-04-07shepherd: Adjust 'fork+exec-command/container' for the Shepherd 0.9....Ludovic Courtès 2022-03-01initrd: Honor rootfstype and rootflags command-line parameters....Maxim Cournoyer 2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer 2022-02-17build: linux-boot: Expound docstring of the 'boot-system' procedure....Maxim Cournoyer 2022-02-07build: image: Account for fixed-size file system structures....Tobias Geerinckx-Rice