aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-10-27 21:38:14 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-28 12:29:38 +0800
commitbc00808ca81573ee0e1b8163c9d42617519923f5 (patch)
tree1726beaee43c43015a7c043fe9641a200270ca7a /gnu/packages
parent9d6f10e8756e8205740114deb61b7bf57ac7b4fe (diff)
downloadguix-bc00808ca81573ee0e1b8163c9d42617519923f5.tar.gz
guix-bc00808ca81573ee0e1b8163c9d42617519923f5.zip
gnu: Remove ghostwriter.
* gnu/packages/text-editors.scm (ghostwriter): Remove variable. Change-Id: I3bf4f80a232539bad72dec1110734408d5054453 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index bfd9a7a060..fae021f012 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -89,7 +89,6 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
- #:use-module (gnu packages hunspell)
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
@@ -869,61 +868,6 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
@end itemize")
(license license:lgpl2.1+)))
-(define-public ghostwriter
- (package
- (name "ghostwriter")
- (version "2.1.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/wereturtle/ghostwriter")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1w8a6vkhmdbp4kzb7aprvfni9ny47dj0vigbcnsh539dn3sp1gan"))))
- (build-system gnu-build-system)
- (native-inputs
- (list pkg-config qttools-5)) ; for lrelease
- (inputs
- (list bash-minimal
- hunspell
- qtbase-5
- qtdeclarative-5
- qtmultimedia-5
- qtquickcontrols-5
- qtsvg-5
- qtwebchannel-5))
- (propagated-inputs ; To get native-search-path
- (list qtwebengine-5))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "qmake" (string-append "PREFIX=" #$output))))
- (add-after 'configure 'create-translations
- (lambda _
- ;; `lrelease` will not overwrite, so delete existing .qm files
- (for-each delete-file (find-files "translations" ".*\\.qm"))
- (apply invoke "lrelease" (find-files "translations" ".*\\.ts"))))
- ;; Ensure that icons are found at runtime.
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (string-append #$output "/bin/ghostwriter")
- `("QT_PLUGIN_PATH" ":" prefix
- #$(map (lambda (label)
- (file-append (this-package-input label)
- "/lib/qt5/plugins"))
- '("qtsvg" "qtmultimedia")))))))))
- (home-page "https://wereturtle.github.io/ghostwriter/")
- (synopsis "Write without distractions")
- (description
- "@code{ghostwriter} provides a relaxing, distraction-free writing
-environment with Markdown markup.")
- (license license:gpl3+))) ; icons/* under CC-BY-SA3
-
(define-public manuskript
(package
(name "manuskript")