aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:10:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:43 +0200
commitb90f9a8988c1156430aa2f40dfcfa70174c8e55d (patch)
tree63adebf2bab20027c3633f4acce74aea85a3bc1a /gnu/packages
parent081a45810756c6dfaeaa875b012e99ce60deb7b2 (diff)
downloadguix-b90f9a8988c1156430aa2f40dfcfa70174c8e55d.tar.gz
guix-b90f9a8988c1156430aa2f40dfcfa70174c8e55d.zip
gnu: Add texlive-kluwer.
* gnu/packages/tex.scm (texlive-kluwer): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 59922cc3d4..0c1349a2ff 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18266,6 +18266,40 @@ The font is distributed in Metafont format, and covers the numbers and
upper-case letters.")
(license license:public-domain)))
+(define-public texlive-kluwer
+ (package
+ (name "texlive-kluwer")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/kluwer/" "doc/latex/kluwer/"
+ "source/latex/kluwer/" "tex/latex/kluwer/")
+ (base32
+ "14y95srzggd8kaiyjq0sz5amvmppl3rilhj9fr0vcjsy2g1ms52z")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; The "kluwer.ins" file only generates "kluwer.cls". To that
+ ;; effect, it needs data from files located in
+ ;; "tex/latex/kluwer/". Bring them to build directory.
+ (add-before 'build 'bring-data-files
+ (lambda _
+ (for-each (lambda (f) (install-file f "build/"))
+ (find-files "tex/latex/kluwer/" "\\.(clo|sty)$")))))))
+ (home-page "https://ctan.org/pkg/kluwer")
+ (synopsis "@emph{Kluwer} publication support")
+ (description
+ "This package provides a class file for @emph{Kluwer} journal
+submissions, and bibliography style for named references. It also includes
+@file{klucite.sty}, which collapses bibliographic citations, and
+@file{klups.sty}, which attempts to select Times for text and MathTime for
+math instead of Computer Modern. This package is most likely long obsolete,
+unfortunately.")
+ (license license:knuth)))
+
(define-public texlive-kotex-oblivoir
(package
(name "texlive-kotex-oblivoir")