aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-10-11 10:51:32 -0500
committerjgart <jgart@dismail.de>2024-10-11 11:21:37 -0500
commitb8fd792ea267cb920da0651074a533d8abf00488 (patch)
treeda24c8954f6e47a6a6fbd309dfab6357e83aaa62 /gnu/packages
parentc278109a89cbf2df1b22cdcd98a8d24289d0f621 (diff)
downloadguix-b8fd792ea267cb920da0651074a533d8abf00488.tar.gz
guix-b8fd792ea267cb920da0651074a533d8abf00488.zip
gnu: python-docstring-to-markdown: Enable tests.
* gnu/packages/python-xyz.scm (python-docstring-to-markdown): Enable tests. [build-system]: Use pyproject-build-system. [arguments]: Reduce test coverage since failing. [native-inputs]: Add missing test inputs. [description]: Improve. Change-Id: I91f1ca3f2d8e7c8fe3fe7b280eba6e4a420d7d93
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19ba2fa981..8c7e1596e6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1538,13 +1538,25 @@ variables into the markdown template")
(uri (pypi-uri "docstring-to-markdown" version))
(sha256
(base32 "0gdpabnyl1kyy0cjrnph6xl4fyhgim50a1amsaqq3hahki6i2ip1"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'reduce-test-coverage-since-failing
+ (lambda _
+ (substitute* "setup.cfg"
+ (("(^.*cov.*$|^.*flake8.*$)") "")))))))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-pytest-flake8))
(home-page "https://github.com/python-lsp/docstring-to-markdown")
(synopsis "On the fly conversion of Python docstrings to markdown")
(description
- "This module can convert Python docstrings to Markdown.
-It can recognise reStructuredText inside docstrings and convert multiple of its
-features to Markdown. It also includes initial support for Google-formatted docstrings.")
+ "This module can convert Python docstrings to Markdown. It can recognise
+reStructuredText inside docstrings and convert multiple of its features to
+Markdown. It also includes initial support for Google-formatted docstrings.")
(license license:lgpl2.1+)))
(define-public python-mysql-connector-python