aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:40 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:52 +0000
commitb764e1c9492ca6760a90c130b85554f4b331a655 (patch)
tree85bb0cd915bdf3760e79f27306974fd82d95d2b3 /gnu/packages
parent0cb10b21b20286d91c4b23de81a256b76bc1c34e (diff)
downloadguix-b764e1c9492ca6760a90c130b85554f4b331a655.tar.gz
guix-b764e1c9492ca6760a90c130b85554f4b331a655.zip
gnu: python-sphinx-autodoc-typehints: Move to pyproject-build-system.
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Move 'check phase replacement... ... to argument <#:test-flags>. Change-Id: I2b41dffd5ee35442e1bb42f426bff69e17648785 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b6fe561d00..ef47be148d 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1155,9 +1155,12 @@ enabled web server.")
(sha256
(base32
"049dlay21f4bccig31fkbzq2m8v0h6g63p1cn3dxay9q3h0mzgs0"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
+ ;; This test requires to download an objects.inv file
+ ;; from the Sphinx website.
+ #:test-flags '(list "-k" "not test_format_annotation")
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pretend-version
@@ -1165,14 +1168,7 @@ enabled web server.")
;; without the git metadata available, the version string is set to
;; '0.0.0'.
(lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests"
- ;; This test requires to download an objects.inv file
- ;; from the Sphinx website.
- "-k" "not test_format_annotation")))))))
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
(propagated-inputs (list python-sphinx))
(native-inputs
(list python-nptyping