aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-31 08:00:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-31 14:38:44 +0200
commitb7466215cd05c2a1cd7c7a18c92af30376d21043 (patch)
tree6c36c950fffa3b4e576a3703fa34e9afcf9c37d6 /gnu/packages
parent94b5db7bbc28195de29d71caf219330dc960dbad (diff)
downloadguix-b7466215cd05c2a1cd7c7a18c92af30376d21043.tar.gz
guix-b7466215cd05c2a1cd7c7a18c92af30376d21043.zip
gnu: go-github-com-stretchr-testify-bootstrap: Move to golang-check.scm
* gnu/packages/golang.scm (go-github-com-stretchr-testify-bootstrap): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Iaa32e1c17a0e5a372613302e5e7fbf8de4d9572a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-check.scm12
-rw-r--r--gnu/packages/golang.scm11
2 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 42e501a6e3..ec886985d6 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -414,6 +414,18 @@ Features include:
@end itemize")
(license license:expat)))
+(define-public go-github-com-stretchr-testify-bootstrap
+ (hidden-package
+ (package
+ (inherit go-github-com-stretchr-testify)
+ (arguments
+ '(#:import-path "github.com/stretchr/testify"
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs
+ (list go-gopkg-in-yaml-v3)))))
+
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 476edf6b4d..ea809f9be0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4466,17 +4466,6 @@ Go.")
slices, JSON and other data.")
(license license:expat)))
-(define go-github-com-stretchr-testify-bootstrap
- (package
- (inherit go-github-com-stretchr-testify)
- (arguments
- '(#:import-path "github.com/stretchr/testify"
- #:tests? #f
- #:phases (modify-phases %standard-phases
- (delete 'build))))
- (propagated-inputs
- (list go-gopkg-in-yaml-v3))))
-
(define-public go-github-com-technoweenie-multipartstreamer
(package
(name "go-github-com-technoweenie-multipartstreamer")