aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-01 21:12:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:10 +0100
commitb6085ae28d1c9e3e45a99ab608861a8cf8678dbf (patch)
tree18463bf8c4d0a1bb24a20e8547965a84e82b6797 /gnu/packages
parent593327e9f1656b7b3916da7e43ac0d2206da4280 (diff)
downloadguix-b6085ae28d1c9e3e45a99ab608861a8cf8678dbf.tar.gz
guix-b6085ae28d1c9e3e45a99ab608861a8cf8678dbf.zip
gnu: Add go-github-com-pion-rtcp.
* gnu/packages/golang-web.scm (go-github-com-pion-rtcp): New variable. Change-Id: I48254c0d41d377da7274cd91ec0967d62fc89848
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1238cfc8c9..4de417cd30 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3674,6 +3674,33 @@ part of @url{https://github.com/pion, Pion} WebRTC implementation.")
((#:import-path flags ''())
"github.com/pion/mdns/v2")))))
+(define-public go-github-com-pion-rtcp
+ (package
+ (name "go-github-com-pion-rtcp")
+ (version "1.2.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/rtcp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00hfq0l17zq47slzfbrghgfc0v808hqiyaab3ni9kh1v7nmvp5ic"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/rtcp"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/pion/rtcp")
+ (synopsis "Implementation of RTCP protocol in Golang")
+ (description
+ "Package rtcp implements encoding and decoding of RTCP packets according
+to @url{https://www.rfc-editor.org/rfc/rfc3550, RFC 3550},
+@url{https://www.rfc-editor.org/rfc/rfc5506, RFC 5506}.")
+ (license license:expat)))
+
(define-public go-github-com-pion-rtp
(package
(name "go-github-com-pion-rtp")