aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:36:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:20 +0200
commitb42c197a515f4ab266623306937ea713d5f4d01f (patch)
tree9a4e8f88436d0e345f32d5ba41bad7c389581449 /gnu/packages
parent16a99693646002839bee50a39f0ffb9bede8a8da (diff)
downloadguix-b42c197a515f4ab266623306937ea713d5f4d01f.tar.gz
guix-b42c197a515f4ab266623306937ea713d5f4d01f.zip
gnu: Add texlive-ttfutils.
* gnu/packages/tex.scm (texlive-ttfutils): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 984d6797e2..0059a0c8eb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6070,6 +6070,36 @@ which produced lines at an arbitrary orientation. The present package
emulates the macro, using TikZ.")
(license license:public-domain)))
+(define-public texlive-ttfutils
+ (package
+ (name "texlive-ttfutils")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/ttf2afm.1"
+ "doc/man/man1/ttf2afm.man1.pdf"
+ "doc/man/man1/ttf2pk.1"
+ "doc/man/man1/ttf2pk.man1.pdf"
+ "doc/man/man1/ttf2tfm.1"
+ "doc/man/man1/ttf2tfm.man1.pdf"
+ "doc/man/man1/ttfdump.1"
+ "doc/man/man1/ttfdump.man1.pdf"
+ "doc/ttf2pk/"
+ "fonts/enc/ttf2pk/base/"
+ "fonts/sfd/ttf2pk/"
+ "ttf2pk/")
+ (base32
+ "1yfr3yic0bx73imxhmxhnhjc1mpwy9f55sh3p430p2f2yvxwm0cs")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ttfutils")
+ (synopsis "Convert TrueType to TFM and PK fonts")
+ (description
+ "This package provides utilities to convert TrueType to TFM and PK fonts:
+@command{ttf2afm}, @command{ttf2pk}, @command{ttf2tfm}, and
+@command{ttfdump}.")
+ (license license:gpl2+)))
+
(define-public texlive-twemojis
(package
(name "texlive-twemojis")