aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-08-14 15:05:49 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-08-14 15:14:28 -0700
commitb30614b28cdc4eb893eeea4523109769f913499e (patch)
tree2f396500c68751f383ee4b85ac44f25f1aec6448 /gnu/packages
parent51f978f4ad796e8e44a0a19ee5ab468b4b8a3958 (diff)
downloadguix-b30614b28cdc4eb893eeea4523109769f913499e.tar.gz
guix-b30614b28cdc4eb893eeea4523109769f913499e.zip
gnu: itpp: Remove non-deterministic log file.
* gnu/packages/maths.scm (itpp)[arguments]: Add 'delete-formulas-log phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c79058ab42..b82987e7a2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1824,6 +1824,12 @@ the resulting text.")
(arguments `(#:tests? #f ; Tests require googletest *sources*
#:phases
(modify-phases %standard-phases
+ (add-after 'install 'delete-formulas-log
+ ;; Contains date and timing information which is unreproducible,
+ ;; and should not be needed when using the package
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/share/doc/itpp/html/_formulas.log")))))
(add-after 'unpack 'set-man-page-date
(lambda _
(substitute* "itpp-config.1.cmake.in"
pos;no-mount-as-root? 'noroot) ('file-name 'path) ('mount-point 'mountpoint) ('ssh? 'ssh) ('file-system-key-cipher 'fskeycipher) ('file-system-key-hash 'fskeyhash) ('file-system-key-file-name 'fskeypath) (_ field-name))) (define-maybe string) (define (serialize-string field-name value) (list (field-name->tag field-name) value)) (define (integer-or-range? value) (match value ((start . end) (and (integer? start) (integer? end))) (_ (number? value)))) (define-maybe integer-or-range) (define (serialize-integer-or-range field-name value) (let ((value-string (match value ((start . end) (format #f "~a-~a" start end)) (_ (number->string value))))) (list (field-name->tag field-name) value-string))) (define-maybe boolean) (define (serialize-boolean field-name value) (let ((value-string (if value "1" "0"))) (list (field-name->tag field-name) value-string))) (define-configuration pam-mount-volume (user-name maybe-string "User name to match.") (user-id maybe-integer-or-range "User ID, or range of user IDs, in the form of @code{(start . end)} to\nmatch.") (primary-group maybe-string "Primary group name to match.") (group-id maybe-integer-or-range "Group ID, or range of group IDs, in the form of @code{(start . end)} to\nmatch.") (secondary-group maybe-string "Match users who belong to this group name as either a primary or secondary\ngroup.") (file-system-type maybe-string "File system type of volume being mounted.") (no-mount-as-root? maybe-boolean "Do not use super user privileges to mount this volume.") (server maybe-string "Remote server this volume resides on.") (file-name maybe-string "Location of the volume to be mounted.") (mount-point maybe-string "Where to mount the volume in the local file system.") (options maybe-string "Options to pass to the underlying mount program.") (ssh? maybe-boolean "Whether to pass the login password to SSH.") (cipher maybe-string "Cryptsetup cipher named used by volume.") (file-system-key-cipher maybe-string "Cipher name used by the target volume.") (file-system-key-hash maybe-string "SSL hash name used by the target volume.") (file-system-key-file-name maybe-string "File name for the file system key used by the target volume.")) (define (pam-mount-volume->sxml volume) ;; Convert a list of configuration fields into an SXML-compatible attribute ;; list. (define xml-attrs (filter-map (lambda (field) (let* ((accessor (configuration-field-getter field)) (value (accessor volume))) (and (not (eq? value %unset-value)) (list (field-name->tag (configuration-field-name field)) value)))) pam-mount-volume-fields)) `(volume (@ ,@xml-attrs))) (define (pam-mount-volume-rules volumes) (map pam-mount-volume->sxml volumes)) (define pam-mount-volume-service-type (service-type (name 'pam-mount-volume) (extensions (list (service-extension pam-mount-service-type pam-mount-volume-rules))) (compose concatenate) (extend append) (default-value '()) (description "Mount remote volumes such as CIFS shares @i{via} @acronym{PAM, Pluggable Authentication Modules} when logging in, using login credentials.")))