aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-09-12 11:05:57 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-09-12 11:29:35 -0400
commitb2f5a9dd67352e035121c70cfdb34cd440c42e98 (patch)
tree09a3775c8168ef608dea62ec4c05216d7ec8d594 /gnu/packages
parentd4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25 (diff)
downloadguix-b2f5a9dd67352e035121c70cfdb34cd440c42e98.tar.gz
guix-b2f5a9dd67352e035121c70cfdb34cd440c42e98.zip
gnu: Add embree-3.
Fixes <https://issues.guix.gnu.org/73186>. Followup to commit 31a55a652f8e4856fd66b47377e214b7d20b4f61 which updated embree; libigl needs an older version. * gnu/packages/engineering.scm (embree-3): New variable. * gnu/packages/engineering.scm (libigl)[inputs]: Replace embree with embree-3 Change-Id: I8c1f038b918c8f4411fec7f53703945df6e6008a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/graphics.scm15
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 26f47dbf9d..db35c2532c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3845,7 +3845,7 @@ perform various useful functions such as:
`(("boost" ,boost)
("cgal" ,cgal)
("eigen" ,eigen)
- ("embree" ,embree)
+ ("embree" ,embree-3)
("glfw" ,glfw-3.4)
("gmp" ,gmp)
("mesa" ,mesa)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e68587658a..3d03802245 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -475,6 +475,21 @@ Embree is meant to increase performance of photo-realistic rendering
applications.")
(license license:asl2.0)))
+(define-public embree-3
+ (package
+ (inherit embree)
+ (name "embree")
+ (version "3.3.15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/embree/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kcvz7g6j56anv9zjyd3gidxl46vipw0gg82lns12m45cd43iwxm"))))))
+
(define-public openvdb
(package
(name "openvdb")