aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIvan Vilata i Balaguer <ivan@selidor.net>2024-10-23 14:00:30 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-02 23:18:53 +0100
commita857a58d65de3674a5b3ff1155f0821c4a7fef71 (patch)
tree642462574bda21265351d9b6bccca991203c9336 /gnu/packages
parentabda22ecb103947372c7359c9e94dab7121f4217 (diff)
downloadguix-a857a58d65de3674a5b3ff1155f0821c4a7fef71.tar.gz
guix-a857a58d65de3674a5b3ff1155f0821c4a7fef71.zip
gnu: povray: Fix test run requiring interaction.
[[PGP Signed Part:No public key for 3DECC105F5DD2382 created at 2024-10-23T14:00:24+0200 using RSA]] The test render required pressing a key after it was done, which caused the package build to get stuck. Also disable the render display window, which did not cause issues but was pointless. * gnu/packages/graphics.scm (povray)[args]: Patch test render not to pause nor display a window. Change-Id: Ia9527b3a67896972b399464b97dda464365d41ea Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/graphics.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8686cac7f7..f33e9d3fcb 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1642,7 +1643,9 @@ in Julia).")
(setenv "HOME" (getcwd))
(with-directory-excursion "unix"
(substitute* "prebuild.sh"
- (("/bin/sh") (which "sh")))
+ (("/bin/sh") (which "sh"))
+ ;; Make test run non-interactive.
+ (("biscuit.pov -f \\+d \\+p \\+v") "biscuit.pov -f +v"))
(invoke "sh" "prebuild.sh"))))
;; The bootstrap script is run by the prebuild script in the
;; "run-prebuild" phase.