aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:53:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:59 +0200
commita566b1dc4da4943b7872cf9f9d5240a537f0801f (patch)
tree81dbceb8ce56af3fe9364eddb109a1712701d0d6 /gnu/packages
parent6e583b00b572409dd26af7948099c679bd35ffb4 (diff)
downloadguix-a566b1dc4da4943b7872cf9f9d5240a537f0801f.tar.gz
guix-a566b1dc4da4943b7872cf9f9d5240a537f0801f.zip
gnu: Add texlive-blochsphere.
* gnu/packages/tex.scm (texlive-blochsphere): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d5b1f82a32..4c4097f64d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16248,6 +16248,29 @@ figures in the document. There is an option to use automatic file naming:
useful if the trees are often moved around.")
(license license:lppl1.3+)))
+(define-public texlive-blochsphere
+ (package
+ (name "texlive-blochsphere")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/blochsphere/"
+ "source/latex/blochsphere/"
+ "tex/latex/blochsphere/")
+ (base32
+ "03gl19r0cc1ajychh6f31bdjqpmmlk0cxg1akxg3h47yrf2np245")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/blochsphere")
+ (synopsis "Draw pseudo-3D diagrams of Bloch spheres")
+ (description
+ "This package is used to draw pseudo-3D Blochsphere diagrams. It
+supports various annotations, such as great and small circles, axes, rotation
+markings and state vectors. It can be used in a standalone fashion, or nested
+within a @code{tikzpicture} environment by setting the environment option
+@code{nested} to @code{true}.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")