aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEmmanuel Beffara <manu@beffara.org>2023-07-20 16:51:25 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:03 +0200
commita51507e58246aac52fcd6ccb475073578a543162 (patch)
tree9b8ae3435bc7dee7ceff9aa3accb6bec3c932c04 /gnu/packages
parent85662a15a8d509e89bed3d756041b1acc1beef74 (diff)
downloadguix-a51507e58246aac52fcd6ccb475073578a543162.tar.gz
guix-a51507e58246aac52fcd6ccb475073578a543162.zip
gnu: cups-filters: Add coreutils and sed to wrapped PATH.
* gnu/packages/cups.scm (cups-filters) [arguments]: Add coreutils and sed to PATH in wrap-filters phase. [inputs]: Add coreutils and sed. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cups.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 2faf0d7a37..9966573834 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -199,9 +199,11 @@ driver is known to work with these printers:
(wrap-program file
`("PATH" ":" prefix
(,(string-append
+ #$(this-package-input "coreutils") "/bin:"
#$(this-package-input "ghostscript-with-cups")
"/bin:"
- #$(this-package-input "grep") "/bin")))))
+ #$(this-package-input "grep") "/bin:"
+ #$(this-package-input "sed") "/bin")))))
(find-files (string-append #$output
"/lib/cups/filter"))))))))
(native-inputs
@@ -212,6 +214,7 @@ driver is known to work with these printers:
pkg-config)))
(inputs
(list avahi
+ coreutils
fontconfig
freetype
font-dejavu ; also needed by test suite
@@ -226,6 +229,7 @@ driver is known to work with these printers:
glib
qpdf
poppler
+ sed
cups-minimal))
(home-page "https://wiki.linuxfoundation.org/openprinting/cups-filters")
(synopsis "OpenPrinting CUPS filters and backends")