aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorunmush <unmush@hashbang.sh>2024-11-27 00:56:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-22 15:37:35 +0200
commita46816dcd155e0544e745deb7256362574fe3154 (patch)
tree1acd76de297441f53789e19c715b4f65e5e47a8b /gnu/packages
parent8e8653fcfb6081f1e96d7cf876faeeda8bd52e30 (diff)
downloadguix-a46816dcd155e0544e745deb7256362574fe3154.tar.gz
guix-a46816dcd155e0544e745deb7256362574fe3154.zip
gnu: Add libgdiplus.
* gnu/packages/dotnet.scm (libgdiplus): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dotnet.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/dotnet.scm b/gnu/packages/dotnet.scm
index 5be4bfd9af..8db14e0ac5 100644
--- a/gnu/packages/dotnet.scm
+++ b/gnu/packages/dotnet.scm
@@ -1625,3 +1625,47 @@ unused0:")))))
'())
"CSC=mcs"
,@make-flags))))))))))))
+
+(define-public libgdiplus
+ (package
+ (name "libgdiplus")
+ (version "6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mono/libgdiplus.git")
+ ;; The releases aren't tagged.
+ (commit "94a49875487e296376f209fe64b921c6020f74c0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gwmhrddr8kdlfprjqcd6gqiy8p5v8sl9215dbd949j1l76szl9v"))
+ (modules '((guix build utils)))
+ (snippet #~(substitute* "./Makefile.am"
+ (("\\./update_submodules\\.sh")
+ ":")))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake
+ autoconf
+ googletest-1.8
+ libtool
+ pkg-config
+ which))
+ (inputs (list cairo
+ freetype
+ fontconfig
+ gettext-minimal
+ giflib
+ glib
+ libexif
+ libjpeg-turbo
+ libpng
+ libtiff
+ libx11))
+ (synopsis "Open Source implementation of the GDI+ API")
+ (description "Libgdiplus is the Mono library that provides a
+GDI+-compatible API on non-Windows operating systems. It uses Cairo to do
+most of the heavy lifting.")
+ (home-page "https://github.com/mono/libgdiplus")
+ (license license:expat)))