aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:32:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:17 +0200
commita32c0b61ce6747e6a4cf010b889aaf4e30adac71 (patch)
tree0a44352dccba97cc451de8cd3bb2e572717fa1c9 /gnu/packages
parent390dadbc15f4593d097119a6259a4749bf89d03d (diff)
downloadguix-a32c0b61ce6747e6a4cf010b889aaf4e30adac71.tar.gz
guix-a32c0b61ce6747e6a4cf010b889aaf4e30adac71.zip
gnu: Add texlive-metatype1.
* gnu/packages/tex.scm (texlive-metatype1): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 69a2f19efd..34412ab2b3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1917,6 +1917,26 @@ build fonts using the Metafont system.")
(define-deprecated-package texlive-metafont-base texlive-metafont)
+(define-public texlive-metatype1
+ (package
+ (name "texlive-metatype1")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "source/metapost/metatype1/")
+ (base32
+ "1nhbsn33w6zbzbvi3a32ng6ib5dbh0vll9g2c5ssiv1ysxqrg6yq")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/metatype1")
+ (synopsis "Generate Type 1 fonts from MetaPost")
+ (description
+ "The system employs scripts, common utility programs, and a set of
+MetaPost macros to provide a means of expressing the details outline fonts
+directly in the MetaPost language. The system was employed to generate the
+Latin Modern fonts, and the distribution includes an example development of
+Knuth's logo fonts.")
+ (license license:public-domain)))
+
(define-public texlive-mfirstuc
(package
(name "texlive-mfirstuc")