aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2019-07-20 22:39:33 +0800
committer宋文武 <iyzsong@member.fsf.org>2019-07-21 21:04:38 +0800
commita18a27be9f6f6f43cc5909d55712058031de4831 (patch)
tree8771ae82bcef2ac60f04ea38878ab0a2cdc9d075 /gnu/packages
parente6df9c7e85ea48765c152b27c88ba30c50c92bb2 (diff)
downloadguix-a18a27be9f6f6f43cc5909d55712058031de4831.tar.gz
guix-a18a27be9f6f6f43cc5909d55712058031de4831.zip
gnu: Add python-gdal.
For <https://issues.guix.gnu.org/issue/36623>, thank to Arne Babenhauserheide for the original patch. * gnu/packages/geo.scm (python-gdal): New package.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/geo.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e4b6a262c7..8005c46129 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -604,6 +604,25 @@ utilities for data translation and processing.")
;; frmts/mrf/libLERC
license:asl2.0))))
+(define-public python-gdal
+ (package (inherit gdal)
+ (name "python-gdal")
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'chdir
+ (lambda _
+ (chdir "swig/python")
+ #t)))))
+ (native-inputs '())
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (inputs
+ `(("gdal" ,gdal)))
+ (synopsis "GDAL (Geospatial Data Abstraction Library) python bindings")))
+
(define-public postgis
(package
(name "postgis")
ndled one....* gnu/packages/lisp.scm (clisp)[native-inputs]: Add cl-asdf. [arguments]: Add 'replace-asdf' phase. [native-search-paths]: Add XDG_CONFIG_DIRS and XDG_DATA_DIRS. Guillaume Le Vaillant 2020-12-05gnu: ccl: Use system ASDF instead of bundled one....* gnu/packages/lisp.scm (ccl)[native-inputs]: Add cl-asdf. [arguments]: Add 'replace-asdf' phase. [native-search-paths]: Add XDG_CONFIG_DIRS and XDG_DATA_DIRS. Guillaume Le Vaillant 2020-12-05gnu: cl-asdf: Improve priorities of configuration file search....* gnu/packages/patches/cl-asdf-config-directories.patch: New file. * gnu/local.mk (dist_PATCH_DATA): Add it. * gnu/packages/lisp.scm (cl-asdf)[native-inputs]: Add it. [arguments]: Apply the new patch. Co-authored-by: Pierre Neidhardt <mail@ambrevar.xyz> Guillaume Le Vaillant 2020-12-03gnu: lisp-repl-core-dumper: Update to 0.3.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.3.0. Pierre Neidhardt 2020-12-02gnu: lisp-repl-core-dumper: Update to 0.2.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.2.0. Pierre Neidhardt 2020-12-01gnu: Add lisp-repl-core-dumper....* gnu/packages/lisp.scm (lisp-repl-core-dumper): New variable. Pierre Neidhardt 2020-12-01gnu: sbcl: Increase default maximum heap size....* gnu/packages/lisp.scm (sbcl)[arguments]: Build with a max heap size of 3 GiB. Guillaume Le Vaillant 2020-11-30gnu: sbcl: Update to 2.0.11....* gnu/packages/lisp.scm (sbcl): Update to 2.0.11. Pierre Neidhardt 2020-11-30gnu: clisp: Enable ASDF module and parallel build, remove old patch....* gnu/packages/lisp.scm (clisp)[source]: Remove patch that does not seem to be needed anymore. [arguments]: Remove (obsolete?) #:build keyword. Enable ASDF and explicitly enable ffcall, readline, sigsegv. Enable parallel-build since they seem to work now. Pierre Neidhardt 2020-11-22Merge branch 'master' into stagingMarius Bakke 2020-11-20gnu: Add janet....* gnu/packages/lisp.scm (janet): New variable. Pierre Neidhardt 2020-11-07Merge branch 'master' into staging... Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm Marius Bakke 2020-11-02gnu: sbcl: Update to 2.0.10....* gnu/packages/lisp.scm (sbcl): Update to 2.0.10. Pierre Neidhardt 2020-10-20gnu: sbcl: Update to 2.0.9....* gnu/packages/lisp.scm (sbcl): Update to 2.0.9. Pierre Neidhardt 2020-10-13Merge branch 'master' into stagingMarius Bakke 2020-10-13gnu: txr: Update to 244....* gnu/packages/lisp.scm (txr): Update to 244. [native-inputs]: Remove bison and flex. Guillaume Le Vaillant 2020-09-12gnu: cl-asdf: Update to 3.3.4....* gnu/packages/lisp.scm (cl-asdf): Update to 3.3.4. [arguments]: Add small patch for default ASDF configuration. (asdf-substitutions): Remove variable. (sbcl, ecl)[arguments]: Remove call to 'asdf-substitutions'. Guillaume Le Vaillant 2020-09-12build-system: asdf: Switch from bundles to regular compilation....* gnu/packages/lisp.scm (sbcl, ecl)[native-search-paths]: Add 'XDG_CONFIG_DIRS'. * guix/build-system/asdf.scm (asdf-build): Replace 'asd-file' and 'asd-system-name' keywords by 'asd-files' and 'asd-systems'. * guix/build/asdf-build-system.scm (%object-prefix, %lisp-source-install-prefix): Update variables. (install): Update variable. (main-system-name): New variable. (copy-source): Replace 'asd-file' and 'asd-system-name' keywords by 'asd-files' and 'asd-systems'. (configure): New variable. (build, check): Replace 'asd-file' and 'asd-system-name' keywords by 'asd-files' and 'asd-systems'. (create-asd-file, symlink-asd-files): Remove variables. (create-asdf-configuration): New variable. (cleanup-files): Update variable. (%standard-phases): Remove 'create-asd-file' and 'symlink-asd-files' phases. Add 'configure' and 'create-asdf-configuration' phases. * guix/build/lisp-utils.scm (%bundle-install-prefix, normalize-dependency, inputs->asd-file-map, asdf-load-all, compile-system): Remove variables. (compile-systems): New variable. (system-dependencies, compiled-system, generate-system-definition): Remove variable. (test-system): Replace 'asd-file' parameter by 'asd-files'. (generate-executable-for-system): Update variable. (generate-dependency-links, make-asd-file, bundle-asd-file): Remove variables. (make-asdf-configuration): New variable. (build-program, build-image): Set 'XDG_CONFIG_DIRS'. (generate-executable): Update variable. Guillaume Le Vaillant 2020-09-04gnu: txr: Update to 243....* gnu/packages/lisp.scm (txr): Update to 243. Guillaume Le Vaillant 2020-09-02gnu: sbcl: Update to 2.0.8....* gnu/packages/lisp.scm (sbcl): Update to 2.0.8. Pierre Neidhardt 2020-08-18gnu: txr: Update to 242....* gnu/packages/lisp.scm (txr): Update to 242. Guillaume Le Vaillant 2020-08-01gnu: sbcl: Update to 2.0.7....* gnu/packages/lisp.scm (sbcl): Update to 2.0.7. Pierre Neidhardt 2020-07-03gnu: sbcl: Add comment explaining out-of-date version....Make sure no one repeats this mistake. This is a follow-up to commit 809aa3c51c5a0f3d8e3d8133b22684702cb90287. * gnu/packages/lisp.scm (sbcl): Add a comment advising against updating to 2.0.6. Jakub Kądziołka 2020-07-03Revert "gnu: sbcl: Update to 2.0.6."...This reverts commit 1ac4959c6a94a89fc8d3a73239d107cfb1d96240. SBCL 2.0.6 breaks named-readtables and consequently many Common Lisp packages. See https://github.com/melisgl/named-readtables/issues/19. Pierre Neidhardt 2020-07-01gnu: sbcl: Update to 2.0.6....* gnu/packages/lisp.scm (sbcl): Update to 2.0.6. Pierre Neidhardt