aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-14 15:31:21 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:45 +0200
commit9fe0e5b35307e4392d0297095116933a435b2c48 (patch)
tree9a42604f77e5536051b5f5f3e9550f467914ddc8 /gnu/packages
parentc1fbcc748958d3ddd8777df5bd51140199ab80cf (diff)
downloadguix-9fe0e5b35307e4392d0297095116933a435b2c48.tar.gz
guix-9fe0e5b35307e4392d0297095116933a435b2c48.zip
gnu: make-bootstrap: Build with GCC 11 instead of GCC 7.
This fixes a glibc-for-bootstrap build issue on aarch64-linux. * gnu/packages/make-bootstrap.scm (glibc-for-bootstrap)[native-inputs]: Remove. (gcc-for-bootstrap, package-with-relocatable-glibc) (%gcc-static, %gcc-stripped): Depend on ‘gcc’ instead of ‘gcc-7’. Reported-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: Ia7f62f9674873087aa20a9d7da8d25d94b215e5c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/make-bootstrap.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 63c84e93ef..13cf40d37b 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -87,12 +87,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"--enable-static-nss"
,flags))))
- ;; Make sure to build glibc with the same compiler version as the rest
- ;; of the bootstrap. Otherwise it fails to statically link on aarch64.
- (native-inputs
- `(("gcc" ,gcc-7)
- ,@(package-native-inputs base)))
-
;; Remove the 'debug' output to allow bit-reproducible builds (when the
;; 'debug' output is used, ELF files end up with a .gnu_debuglink, which
;; includes a CRC of the corresponding debugging symbols; those symbols
@@ -103,13 +97,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(mlambdaq (glibc)
"Return a variant of GCC that uses the bootstrap variant of GLIBC."
(package
- (inherit gcc-7)
+ (inherit gcc)
(outputs '("out")) ;all in one so libgcc_s is easily found
(inputs
`( ;; Distinguish the name so we can refer to it below.
("bootstrap-libc" ,(glibc-for-bootstrap glibc))
("libc:static" ,(glibc-for-bootstrap glibc) "static")
- ,@(package-inputs gcc-7))))))
+ ,@(package-inputs gcc))))))
(define (package-with-relocatable-glibc p)
"Return a variant of P that uses the libc as defined by
@@ -148,7 +142,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(cons (search-path-specification
(variable "CROSS_CPLUS_INCLUDE_PATH")
(files '("include")))
- (package-search-paths gcc-7)))))
+ (package-search-paths gcc)))))
("cross-binutils" ,(cross-binutils target))
,@(%final-inputs)))
`(("libc" ,(glibc-for-bootstrap glibc))
@@ -472,11 +466,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %gcc-static
;; A statically-linked GCC, with stripped-down functionality.
(package-with-relocatable-glibc
- (package (inherit gcc-7)
+ (package (inherit gcc)
(name "gcc-static")
(outputs '("out")) ; all in one
(arguments
- (substitute-keyword-arguments (package-arguments gcc-7)
+ (substitute-keyword-arguments (package-arguments gcc)
((#:modules modules %default-gnu-modules)
`((srfi srfi-1)
(srfi srfi-26)
@@ -527,7 +521,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inputs
`(("zlib:static" ,zlib "static")
("isl:static" ,isl "static")
- ,@(package-inputs gcc-7)))
+ ,@(package-inputs gcc)))
(native-inputs
(if (%current-target-system)
`(;; When doing a Canadian cross, we need GMP/MPFR/MPC both
@@ -540,13 +534,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("gmp-native" ,gmp)
("mpfr-native" ,mpfr)
("mpc-native" ,mpc)
- ,@(package-native-inputs gcc-7))
- (package-native-inputs gcc-7))))))
+ ,@(package-native-inputs gcc))
+ (package-native-inputs gcc))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.
(package
- (inherit gcc-7)
+ (inherit gcc)
(name "gcc-stripped")
(build-system trivial-build-system)
(source #f)