aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:09:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:26 +0200
commit9c53c8771a85e84686f5cdff3d2cd8600d78cf93 (patch)
treea06a080897c22eefc015d342d7f9b2f30625e9c7 /gnu/packages
parentc7a31936db6333c08ea032177819eb4201bc23b6 (diff)
downloadguix-9c53c8771a85e84686f5cdff3d2cd8600d78cf93.tar.gz
guix-9c53c8771a85e84686f5cdff3d2cd8600d78cf93.zip
gnu: Add texlive-miniplot.
* gnu/packages/tex.scm (texlive-miniplot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 63c66c8a36..75704b6633 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2769,6 +2769,29 @@ control measures, as well as support for custom non-standard symbols. Control
measures are planned to be included in a future release.")
(license license:cc-by-sa4.0)))
+(define-public texlive-miniplot
+ (package
+ (name "texlive-miniplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/miniplot/" "tex/latex/miniplot/")
+ (base32
+ "0k98mfd4bf43br74wyjqjlwb93yzi2b5r53jsrsr58p6lg59c200")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/miniplot")
+ (synopsis "Package for easy figure arrangement")
+ (description
+ "MiniPlot is a package to help the LaTeX user typeset EPS figures using
+an easy-to-use interface. Figures can be arranged as one-figure-only or as
+a collection of figures in columns and rows which can itself contain
+sub-figures in columns and rows. Wrapped figures are also supported. This
+package provides commands to display a framebox instead of the figure as the
+graphics package does already but additionally it writes useful information
+such as the label and scaling factor into these boxes.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")