aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:26 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:50 +0000
commit9be29a2462564fbd0f5e866110b50519ccd7823a (patch)
treef9d17573a20a9823746ffb0cbfe02107a4e7824a /gnu/packages
parent48c92942ab7037d9cae0e81ef82f4f8697c85e03 (diff)
downloadguix-9be29a2462564fbd0f5e866110b50519ccd7823a.tar.gz
guix-9be29a2462564fbd0f5e866110b50519ccd7823a.zip
gnu: python-nbval: Move to pyproject-build-system.
* gnu/packages/python-check.scm (python-nbval): [build-system]: Move to pyproject-build-system. [arguments]: Move <#:phases> check phase replacement into proper <#:test-flags>. [native-inputs]: Add python-pytest. [propagated-inputs]: Add python-six; remove python-pytest. Change-Id: I93aa282399eb52636ee5561b5d8fb7bb5b93f9e0 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm37
1 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index fd1e188788..04e0fafe66 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1699,29 +1699,32 @@ notebooks.")
(uri (pypi-uri "nbval" version))
(sha256
(base32 "154h6xpf9h6spgg3ax6k79fd40j197ipwnfjmf5rc2kvc2bmgjbp"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-test
- (lambda _
- ;; This test fails because of a mismatch in the output of LaTeX
- ;; equation environments. Seems OK to skip.
- (delete-file
- "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- ;; nbdime forms a dependency cycle
- "--ignore=tests/test_nbdime_reporter.py")))))))
- (native-inputs (list python-pytest-cov python-sympy))
+ (list
+ #:test-flags
+ '(list
+ ;; This test fails because of a mismatch in the output of LaTeX
+ ;; equation environments. Seems OK to skip.
+ "--ignore=tests/test_nbdime_reporter.py")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ (lambda _
+ ;; This test fails because of a mismatch in the output of LaTeX
+ ;; equation environments. Seems OK to skip.
+ (delete-file
+ "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb"))))))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-sympy))
(propagated-inputs
(list python-coverage
python-ipykernel
python-jupyter-client
python-nbformat
- python-pytest))
+ python-six))
(home-page "https://github.com/computationalmodelling/nbval")
(synopsis "Pytest plugin to validate Jupyter notebooks")
(description