aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commit9b998a8d63c0855ebec7d01010d2f1f66607b033 (patch)
tree74729454badf12a9092594b80b343941bc9e9192 /gnu/packages
parent4f86fa20179ded1e6314eeba7da17309d501a32f (diff)
downloadguix-9b998a8d63c0855ebec7d01010d2f1f66607b033.tar.gz
guix-9b998a8d63c0855ebec7d01010d2f1f66607b033.zip
gnu: sshuttle: Refer to a fixed ‘sh’ and avoid WHICH.
* gnu/packages/vpn.scm (sshuttle)[arguments]: Use SEARCH-INPUT-FILES for ‘env’ (rather than WHICH) and ‘sh’ (rather than whatever's in $PATH). Change-Id: Ieacae72a849cdcbef4ae9e8f24c0d95879b1dd48
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 4cb871feb2..0f7300ff51 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1005,11 +1005,13 @@ private network between hosts on the internet.")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-FHS-file-names
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "sshuttle/client.py"
- (("/usr/bin/env") (which "env")))
+ (("(/usr)?(/bin/env)" _ _ command)
+ (search-input-file inputs command)))
(substitute* "sshuttle/ssh.py"
- (("/bin/sh") "sh"))))
+ (("/bin/sh" command)
+ (search-input-file inputs command)))))
(add-after 'install 'install-documentation
(lambda _
(with-directory-excursion "docs"