aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:09:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:53 +0200
commit9a8caeec04088d2cd024afb3412c686693d20de7 (patch)
treeeaf6d83c79c8b9c71b786dad3fcf9d35075adf48 /gnu/packages
parent584013f2abfe6c76233bb9c5ef816603c61aff36 (diff)
downloadguix-9a8caeec04088d2cd024afb3412c686693d20de7.tar.gz
guix-9a8caeec04088d2cd024afb3412c686693d20de7.zip
gnu: Add texlive-hanoi.
* gnu/packages/tex.scm (texlive-hanoi): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9edcaa57cd..fb92062b4d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7191,6 +7191,24 @@ programs are provided as sources, not installed in the @file{bin}
directories.")
(license license:public-domain)))
+(define-public texlive-hanoi
+ (package
+ (name "texlive-hanoi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/plain/hanoi/")
+ (base32
+ "09a7cv76naxzdach5507wdqnjp12amvlia7kw0jh224ydmkzfx9x")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hanoi")
+ (synopsis "Tower of Hanoi in TeX")
+ (description
+ "The Plain TeX program (typed in the shape of the towers of Hanoi) serves
+both as a game and as a TeX programming exercise. As a game, it will solve
+the towers with (up to) 15 discs.")
+ (license license:public-domain)))
+
(define-public texlive-happy4th
(package
(name "texlive-happy4th")