aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-09-04 16:56:06 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-04 16:56:06 +0200
commit9a03ab25ba889be27b34d5cebea05d5ac3b0a033 (patch)
tree5e009d92fadae57a2cba9a784a725c2fb8cc5e2f /gnu/packages
parent0e2c312014e934933ca70262a54545a5ffd5217f (diff)
downloadguix-9a03ab25ba889be27b34d5cebea05d5ac3b0a033.tar.gz
guix-9a03ab25ba889be27b34d5cebea05d5ac3b0a033.zip
gnu: python-agate: Fix tests.
* gnu/packages/wireservice.scm (python-agate)[native-inputs]: Add '(libc-utf8-locales-for-target)'. Remove labels. [propagated-inputs]: Remove labels. Change-Id: I85c5fba60e96c4e3bd52f82e8cad9c3ed23d5661
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wireservice.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index 70b4fc0839..df630023cf 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -109,20 +109,21 @@ charts now and don't care if they're perfect.")))
(base32
"1wqyml7f70hr7zhgwvwqy4bdshlbcmp4jmyc5y12jyx10xp3sk7c"))))
(native-inputs
- `(("locales" ,python-agate-locales)
- ("python-nose" ,python-nose)
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("python-csselect" ,python-cssselect)
- ("python-lxml" ,python-lxml)))
+ (list (libc-utf8-locales-for-target)
+ python-agate-locales
+ python-nose
+ python-sphinx
+ python-sphinx-rtd-theme
+ python-cssselect
+ python-lxml))
(propagated-inputs
- `(("python-babel" ,python-babel)
- ("python-isodate" ,python-isodate)
- ("python-leather" ,python-leather)
- ("python-parsedatetime" ,python-parsedatetime)
- ("python-pytimeparse" ,python-pytimeparse)
- ("python-six" ,python-six)
- ("python-slugify" ,python-slugify)))
+ (list python-babel
+ python-isodate
+ python-leather
+ python-parsedatetime
+ python-pytimeparse
+ python-six
+ python-slugify))
(home-page "https://agate.rtfd.org")
(synopsis "Data analysis library")
(description "Agate is a Python data analysis library. It is an