aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:06:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:09 +0200
commit988f6c7059f66f1cee9c1d9d69e5d0bcdc5ebd76 (patch)
tree8b0ae42643a8ddc41a18e5569b43cb84ddcab442 /gnu/packages
parent4fb3442f5bc03914b8f6effc54eb744b6cadc22a (diff)
downloadguix-988f6c7059f66f1cee9c1d9d69e5d0bcdc5ebd76.tar.gz
guix-988f6c7059f66f1cee9c1d9d69e5d0bcdc5ebd76.zip
gnu: Add texlive-fonts-tlwg.
* gnu/packages/tex.scm (texlive-fonts-tlwg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a8656e293..55d8dbc2e3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11643,6 +11643,35 @@ otc) into individual fonts.
@end itemize")
(license license:gpl2)))
+(define-public texlive-fonts-tlwg
+ (package
+ (name "texlive-fonts-tlwg")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/fonts-tlwg/"
+ "fonts/afm/public/fonts-tlwg/"
+ "fonts/enc/dvips/fonts-tlwg/"
+ "fonts/map/dvips/fonts-tlwg/"
+ "fonts/opentype/public/fonts-tlwg/"
+ "fonts/tfm/public/fonts-tlwg/"
+ "fonts/type1/public/fonts-tlwg/"
+ "fonts/vf/public/fonts-tlwg/"
+ "source/fonts/fonts-tlwg/"
+ "tex/latex/fonts-tlwg/")
+ (base32
+ "19g1ksxsidf6cpcxm3knbbfpjw6jsfq2acy99cgmsy7jn33k253b")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fonts-tlwg")
+ (synopsis "Thai fonts for LaTeX from TLWG")
+ (description
+ "This package provides a collection of Thai fonts, supplied as FontForge
+sources, and with LaTeX @file{.fd} files.")
+ (license (list license:gpl2+
+ license:lppl1.3+
+ (license:x11-style "file://source/fonts/fonts-tlwg/COPYING")))))
+
(define-public texlive-fontware
(package
(name "texlive-fontware")