aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:30:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:56 +0200
commit98206c123b1b2b20aa36b9a25154b08077b81337 (patch)
treed038c3720e3d2c9ffc39a408a7e4557fcaabed71 /gnu/packages
parent5c94bf9b13ebc281b39f869b1f3131c34e6946bb (diff)
downloadguix-98206c123b1b2b20aa36b9a25154b08077b81337.tar.gz
guix-98206c123b1b2b20aa36b9a25154b08077b81337.zip
gnu: Add texlive-mathsemantics.
* gnu/packages/tex.scm (texlive-mathsemantics): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 065b3a1cf6..b638657644 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4604,6 +4604,29 @@ for typeseting sets of type inference rules or typing derivations.")
semicolons in mathematical expressions.")
(license license:bsd-2)))
+(define-public texlive-mathsemantics
+ (package
+ (name "texlive-mathsemantics")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mathsemantics/"
+ "tex/latex/mathsemantics/")
+ (base32
+ "06p4i9nx8sh3dv2nzq3vk1m36nshxgalr8c6660ns9kbhraprkbp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mathsemantics")
+ (synopsis "Semantic math commands in LaTeX")
+ (description
+ "This LaTeX package provides both syntactic and semantic helpers to
+typeset mathematics in LaTeX. The syntactic layer eases typesetting of
+formulae in general, while the semantic layer provides commands like
+@code{\\inner@{x@}@{y@}} to unify typesetting of inner products. These not
+only unify typesetting of math formulae but also allow to easily adapt
+notation if a user prefers to. The semantic layer is split into topics.")
+ (license license:expat)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")