aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-19 14:37:19 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-07 01:20:22 +0900
commit970631c36f0369318f184ff3251672d4fc5d24c1 (patch)
tree38e7c503bb462956dd61bf517d23da3e7b2f73eb /gnu/packages
parent294294dd302909a76b3ce6c7ff959aa79d12f300 (diff)
downloadguix-970631c36f0369318f184ff3251672d4fc5d24c1.tar.gz
guix-970631c36f0369318f184ff3251672d4fc5d24c1.zip
gnu: sdl2-gamecontrollerdb: Update to 0-2.414eaee.
* gnu/packages/sdl.scm (sdl2-gamecontrollerdb): Update to 0-2.414eaee. Change-Id: I3e4aea7f2881aebdb24dffdaa38a2248aa00e6bf
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sdl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index dfc49fe395..67cc47d33c 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -608,8 +608,8 @@ directory.")
(properties '((upstream-name . "SDL2_ttf")))))
(define-public sdl2-gamecontrollerdb
- (let ((commit "9d0994523206c9d73925d78d185531c4c7331db7")
- (revision "1"))
+ (let ((commit "414eaee7aacc0d2ccdf281663c3d3bc65a8dbedd")
+ (revision "2"))
(package
(name "sdl2-gamecontrollerdb")
(version (git-version "0" revision commit))
@@ -621,7 +621,7 @@ directory.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "08rv3i6sh90ibphxnv9r6h1zjyq88x9hq3smvf6cnlqvirnam94s"))))
+ (base32 "04x3g7vshagxaklwm5hxawh1pk6j1h0rip9xccpgr1r3gpxqs5df"))))
(build-system copy-build-system)
(arguments
'(#:install-plan '(("gamecontrollerdb.txt" "share/sdl2/"))))
f (lstat(linkPath.c_str(), &stLink)) throw SysError(format("getting attributes of path `%1%'") % linkPath); if (st.st_ino == stLink.st_ino) { printMsg(lvlDebug, format("`%1%' is already linked to `%2%'") % path % linkPath); return; } if (st.st_size != stLink.st_size) { printMsg(lvlError, format("removing corrupted link ‘%1%’") % linkPath); unlink(linkPath.c_str()); goto retry; } printMsg(lvlTalkative, format("linking ‘%1%’ to ‘%2%’") % path % linkPath); /* Make the containing directory writable, but only if it's not the store itself (we don't want or need to mess with its permissions). */ bool mustToggle = !isStorePath(path); if (mustToggle) makeWritable(dirOf(path)); /* When we're done, make the directory read-only again and reset its timestamp back to 0. */ MakeReadOnly makeReadOnly(mustToggle ? dirOf(path) : ""); Path tempLink = (format("%1%/.tmp-link-%2%-%3%") % settings.nixStore % getpid() % rand()).str(); if (link(linkPath.c_str(), tempLink.c_str()) == -1) { if (errno == EMLINK) { /* Too many links to the same file (>= 32000 on most file systems). This is likely to happen with empty files. Just shrug and ignore. */ if (st.st_size) printMsg(lvlInfo, format("`%1%' has maximum number of links") % linkPath); return; } throw SysError(format("cannot link `%1%' to `%2%'") % tempLink % linkPath); } /* Atomically replace the old file with the new hard link. */ if (rename(tempLink.c_str(), path.c_str()) == -1) { int renameErrno = errno; if (unlink(tempLink.c_str()) == -1) printMsg(lvlError, format("unable to unlink `%1%'") % tempLink); if (renameErrno == EMLINK) { /* Some filesystems generate too many links on the rename, rather than on the original link. (Probably it temporarily increases the st_nlink field before decreasing it again.) */ if (st.st_size) printMsg(lvlInfo, format("`%1%' has maximum number of links") % linkPath); return; } throw SysError(format("cannot rename `%1%' to `%2%'") % tempLink % path); } stats.filesLinked++; stats.bytesFreed += st.st_size; stats.blocksFreed += st.st_blocks; } void LocalStore::optimiseStore(OptimiseStats & stats) { PathSet paths = queryAllValidPaths(); InodeHash inodeHash = loadInodeHash(); foreach (PathSet::iterator, i, paths) { addTempRoot(*i); if (!isValidPath(*i)) continue; /* path was GC'ed, probably */ startNest(nest, lvlChatty, format("hashing files in `%1%'") % *i); optimisePath_(stats, *i, inodeHash); } } static string showBytes(unsigned long long bytes) { return (format("%.2f MiB") % (bytes / (1024.0 * 1024.0))).str(); } void LocalStore::optimiseStore() { OptimiseStats stats; optimiseStore(stats); printMsg(lvlError, format("%1% freed by hard-linking %2% files") % showBytes(stats.bytesFreed) % stats.filesLinked); } void LocalStore::optimisePath(const Path & path) { OptimiseStats stats; InodeHash inodeHash; if (settings.autoOptimiseStore) optimisePath_(stats, path, inodeHash); } }